Intersecting does not add intersections to the component

Intersecting does not add intersections to the component. I have 2 components I want to intersect. When I get done the lines of the intersection are not part of the component. If this is normal, what is the easiest way to add them to the component?

Cut them, open the component and Paste in Place.
You need to be in the correct context for the edges to be placed within a component.
In other words, open one component for editing, select all of it (or the relevant parts) and use Intersect Faces with Model. This will place the edges within that context. If you do it outside the context of both it will place the edges outside both, so you can cut and paste in place within if you want.

Thank you so much, I never noticed that paste in place before. I use that feature all the time in Illustrator.

Why does is one of the intersections not connected? I attached the file

Scooter 3.skp (1.6 MB)

There is a tiny gap that shows the edges are not lying flat on the surface. If you turn on the component you can see that it isn’t flat on the face so the intersection hasn’t worked correctly.
Intersection doesn’t always work when two faces come together, the really need to cut through to get a good intersection edge.
Personally in this case I would have just drawn around the uprights while having the bottom open for edit.