Intersected faces, without any faces present

I keep having problems with preparation for 3d-printing models. I model mostly 1:1 scale and reduce to 1/35. In both sizes problems arise when exporting to stl.
For checkup of the model i run Fixit 101, Solid Inspector2 and Claenup when needed. Solidsolver crashes always. Some of the planes then get extra lines (although quite some of them are hidden by sketchup without me being able to select them (select all shows them, Shortcut K won’t) and quite often up to four faces are stacked. But thats all found with solid Inspector.
What baffles me is the faces which are found as errors when I upload to 3dhubs: numerous triangles as errors, which in my checked model are nowhere to be found. I know Sketchup ‘corrects’ things and fought with this problem to no end, but triangular faces which simply do not exist and are not made also, i cannot get my head around.
Do I overlook something?
Is there any way this autocorrecting by Sketchup can be switched off? It would save me so much time without it.
Mac, SKP pro 2021.

Probably scaling the model down creates too small geometry. One thing to try is to export the STL to full scale and try scaling the model in the slicer. Another is to model deliberately to a larger scale, for instance using Meters as Millimeters, and, after scaling down, telling the slicer to use millimeters.

STL means standard triangle language.
So when exporting as STL every face gets to be a triangle. A rectangle will become two triangles, that’s the way STL works…

I know about the trangles. It still does not give an explanation for the phantom triangles which are found on 3dhubs. Trangles (which sometimes even are trangles in their own right as they should be) still are ‘intersected’.
Seems sketchups stl export is not 100% to me.

I’d be interested to see one of your problematic models.

I hadn’t heard of that before. I believed it to be as shown in the export 3D model option, STereoLithography File. Wikipedia does show Standard Triangle Language as a “backronym” for STL. That means it was a made up acronym after STL was already in use.

It’s interesting that export to STL doesn’t have a triangulate all faces option, like some other exporters do, which could imply that it does have to become triangles, but importing an STL file doesn’t reveal any triangles, like you would see when importing a Collada file.

I beg to differ, even a cube stl will import triangulated.

If the STL was made elsewhere, made from triangles. If I export a box from SketchUp and import that again, and don’t use the merge coplanar faces option, it comes in as a box. Show hidden geometry doesn’t show any triangles.

I see you are typing. I came back to say I was wrong! I was looking at the original box and not the reimported one.

Using the merge coplanar faces is a way to get rid of the triangles.

That’s reassuring, since if you look up the specs of stl you will find that the only kind of face geometry it supports is triangles!

You’re quite right about that! Thanks for correcting me.
It doesn’t change the fact that an STL is made of triangles only however.

cckw-tipper-parts.skp (419.8 KB) cckw-tipper-parts.stl (121.1 KB)

Box, the skp, the stl and a screenshot of the ‘errors’.

Thanks for attaching those. One thing I would suggest is you go to Window/Model info/Units and turn off Length snapping. I is known to create inaccuracies.
Having said that, after checking your model and expecting to see tiny errors everywhere I couldn’t fault it. The only comment I could make is that your model is ever so slightly off but accurately to 4 decimal places. You have units set to 1mm so you get a tilde in many measurements.
And a little bit of a mess at one point.
After struggling to find the problem in your .skp I then looked at your .stl to check better where I should look, couldn’t find any issues in the stl.
So I checked your stl and one I exported from your original in 3 different printer software and also found no issues with them.
So it suggests to me the problem is being ‘created’ by/at ‘3dhubs’.
I have no experience with them so I can’t offer any suggestions.


Many thanks for the review Box, I’ll make a new template where the millimeter- and a lot of other settings are smaller etc, because i tend to copy parts to different files not to lose any inbetweens, where i often forget to reset the standard settings to what is needed. One millimeter is way too large in these instances, after reduction.
I will contact 3dhubs with this ssame set of files and will let you know what is done.

Hi Peter,
I do have the same type of diagnostic ‘50 intersecting faces’ , with several models I submited to…!
My models are clean solid groups also…
Did you have an answer to your request to
Thanks for your help.

Their answer was to ignore them, but i still have not ordered yet. Need to add some parts.

Good news ! That’s pretty engaging…
Thanks Peter