Intersect Faces with - Model vs. Selection

Need to notch the larger object around the longer rafter. When I use intersection with selection, the cut lines end up on the rafter. Need the cut lines on the larger object. Thank you for your suggestions/comments.

*Rafter is angled, blocking plate has beveled edges to match.

Couple of questions:

  1. Is the order of selection important?

  2. What is the difference in model vs. selection? (Tried both, no difference)

  3. Is there a better solution than Intersect Faces?

InstesectFaces.skp (506.5 KB)

Finally got it to work (not sure how), but there is one edge missing.

No missing edge. SketchUp is a face modeller. However, if your parts are “solid” groups or components, you can use Solid tools (Substract or Trim) to perform this operation in one go.

1 Like

Thanks. So, what I called a “missing edge” is due to the edge being internal to the component, is that correct? But, in order for this section to be removed, I need that edge? After adding the edge, I arrived at the solution, but way too much editing! And these components are not solids.

Anssi, I turned these components into solids and used Solid Tools, as you suggested. Worked as expected. But, the side effect, is Solid Tools turns components into groups.

I think DaveR mentioned an alternative to Solid Tools, but I forgot the name of the extension. After a search, found it, Eneroth Solid Tools.

You can do this with “intersect faces” and not much editing. It is just practice with the sequence and how you select objects. Getting used to the different intersect faces options takes some tries too, but it’s just the concepts that are hard to grasp at first. If these are the only objects in the model then “with model” and “with context” and “with selected” give the same results.

Order of selection doesn’t matter. It allows you to select a couple objects or just faces and only have them interact with the selection --and not have other faces create intersections when you don’t want them to.

Which component gets the Intersect faces edges depends not on which you select first, but whether, and if so which, you have open for editing, and which of its faces you select for intersection.

The difference between ‘With model’, ‘With context’ and ‘With selection’ affects what other parts of your model the Intersect faces checks against your selected faces.

‘With model’ checks each selected face with all of the rest of the model. In a big model, that can be very slow.

‘With context’ checks each selected face agains all other objects and faces in the same context as the faces you have selected.

And ‘With selection’ does the checking, each selected face with any other objects or faces you have selected when you run the Intersect faces.

So in your original question where you wanted the intersection edges to be in the blocking plate, open that for editing, and use ‘With model’ to intersect it with the rafter.

Then push pull the cut out to clear it, and erase any other stray edges.

Assuming (as you should have) that both rafter and blocking plate are already components…

When you have the blocking plate open for editing, there’s nothing else to intersect with in the same context (the ‘inside’ of the blocking plate).

And while it is open, you can’t select the rafter.

So ‘with model’ is the only option that can work, and the others will be grayed out.

If you were temporarily to explode the blocking plate, and if it intersected with (say) two rafters, you could select all of the blocking plate, and both the rafter components, then use ‘with selection’,

Does that clarify, or just confuse, Claire?

Hi John,

Still having issues with Intersect Faces. The behavior seems inconsistent. Two solids, but no options to choose. Take a look at the GIF.

I have searched for but unable to find a deep dive into the “Intersect Faces” command. Seems to me this command is a core capability. I would gladly create a training video, but as you see I am not a good candidate. Maybe after I fully explore and understand, I will come back to this subject.

Well, second Monday this week. Forgot to select the components, but did not make a difference. What did, was using the right-click-fly-out menu. But as you can see, the intersection only occurred on the rafter not the block, regardless whether model or selection.

For a new user, having the menus on top and the right-click-fly-out produce different results leads to confusion and frustration.

In your video, Intersect Faces is unavailable as you don’t have any faces selected. If you double click on the “Front Blocking” component to edit it, select all, then right click -> Intersect Faces->With Model.

As you have Pro and both your components are solid, you could just use solid tools Trim. Select the rafter, choose Trim, click on the plate to cut a hole in the plate to fit the rafter.

The key thing to understand about “Intersect Faces” is that no matter which option you choose, it places any new edges and faces into the currently active edit context. Intersect with model won’t cause the edges to go into the model if a component is open for edit.

1 Like

In reply to your edit after my post

The intersection was ‘on’ the rafter but not inside the rafter component, so it wasn’t any more ‘on’ the rafter than it was ‘on’ the plate. If you want the lines inside your plate component, you’d have to enter that component for editing by double-clicking on it first. Then select at least one face. Then do intersect faces -> with model and the lines will be placed inside your plate component.

If you selected all entities inside the plate component it would look for intersections between all the faces and the model. Or you could just choose certain faces that you wanted to intersect with the model which is sometimes useful.

Using your instructions, produced a different result. Now the cut is on the blocking component, which is what I needed. But, as you can see there are missing edges, and trying to manually edit produces another mess.

And yes, I have tried Solid Tools, and can succeed, but with a cost of losing the component status. And yes, I then tried Eneroth Solid Tools to solve that issue. But, I really would like to understand and use effectively, the native tool, Interset Faces. Thanks.

I think the edges you count as being missing are where SketchUp doesn’t see any intersections, so doesn’t add an edge. The top of your block is in the same plane as the top sloping face of the rafter, so no intersection. The same goes for the side face of the rafter being co-planar with the end of your block.

You’ll have a bit of manual tidying up with intersect faces but it gives you the important edges where they intersect to work from.

Thanks McGordon, you have a gift for clear explanations. You continue to further my SU education with your posts.

Understanding the finer details of Intersect Faces is important when confronted with a scenario like this one. I now understand your comment about possibly using Solid Tools as a solution. Having all the newly found knowledge, I would have eagerly utilized Eneroth Solid Tools.

Still interested in finding a SU reference that would have allowed me to self-teach, but having folks like yourself is invaluable. Thanks again for your patience and help.

The angle on the top/bottom faces on the blocking component and the rafter are identical as you point out. But, when I was accidentally intersecting with the wrong faces on the rafter, all the edges were present after the intersection (see GIF). So, why would we not expect the same result whether on the rafter or the blocking component?

If the faces are exactly aligned SketchUp will not see an intersection–well sometimes it does. So don’t try it (or don’t expect it) unless there’s a full intersection. For an intersection like this, I might see if drawing an edge and using push-pull is a faster approach. Are you trying to trim the block? Is the block made up of parallel faces?

Those lines are on the rafter. If you place all the faces together --not separated by groups then you’ll have all the faces needed. Copy the rafter and place it in the block group (paste in place command) explode the rafter, select all and intersect with context. remove excess --you may have to reverse the faces of the cut.

This is why solid tools were invented after being developed by plugin designers.

Faces are exactly aligned. Both components are solids. Inconsistent behavior leads me to not trust the tool (Intersect Faces).

Yes.

Yes.

These components are from a model with 237 rafters and blocking plates. Really do not want to change the component status.

I am starting to appreciate the solid tools (not SU native), but certainly Eneroth’s version.

Thanks,

It is not a big deal to enter the component ‘wrapper’ of the rafter and group the geometry inside it (Double click to edit component, Triple click, Make group)
Back in the model, select the larger part, Copy it, enter the rafter for editing, Paste the clipcontent ‘in Place’ and then subtract it from the group inside the Rafter.

You are not changing the component status, you are modifying the block component You only paste a copy of the rafter to the block component. There are definite limitations. I don’t use intersect faces if the faces are aligned. LIke I said, in such a case I probably would not use either tool, as it is easier to draw a line on the block and push-pull the cut.

But, in this case, with the bevels (angles), you simply cannot use push/pull (see image).

That’s true in those directions. But a line on the END of the block under the rafter? I don’t know how your block is. I am imagining a block cut from a board (therefore all side edges are parallel in direction of grain) if you draw a line under the rafter and go with the grain of the block (toward the camera in this case).

Definitely, if it is more complex—the top cut of the block, or rafter is skewed, that is where solid tools are best.