Imported images doesn't show anymore


#1

So been applying graphics (import, then use as image) quite happily to SU models in Pro 14, a pain with curves etc
but flat faces easy.

Now when I apply them in SU they show fine in the model as normal but when I go to render nothing shown?

If I explode the imported image it disappears, i’ve tried lots of file formats and same happens.

Any ideas? Is this SU or Twilight render?


#2

Some renderer’s don’t display Images - but when exploded into a Textured Material or initially imported as a Texture, then they should show up.
If you explode the Image whilst it’s over a reversed face, then the newly added material might only get applied to the back of that face.
Some renderers don’t process rear faces beyond a default color.
If you view the model in Monochrome mode with a distinctive back-face default-material set in your Style, what do you see ?
Reversed faces are a no-no for most renderers…
Try testing with the simplest of models with the Image and a face using a similar textured-material, both standing up on end [i.e. vertical].
Note how the normal for a new face made flat on the ground is always ‘downwards’ - so you’ll see its back - this is because SketchUp assumes you’ll want to PushPull it upwards and that will be the correct orientation to keep the new form’s bottom face afterwards…


#3

thanks for the comprehensive response.

I tried push pull in various planes to see if that effected it.

Turned out I need to cross a line on the face having the image applied, after doing that it works fine, why? I know not, but it works

thanks again