Imported .dwg file vanishes on orbit?


#1

I’m on the 30 day trial of SketchUp pro and in a hurry. I blocked a floor plan from AutoCAD 13 layer 0 only Arch 1/64" and imported it and aligned it with origin in horizontal plane. I blocked a section through the site of the same plan and imported it to use as the western boundary projection plane. They are both separate components on separate layers. 1ST FLOOR PLAN & WESTERN ELEVATION… I aligned the western elevation .dwg with the origin and rotated it 90 degrees counter clockwise from the X or green axis so that it lined up on the red Y axis so I could rotate it vertically in the red Y axis to use as a projection guide for the plan extrusions. To do so I need to use orbit to get under the plan view and zoom in on the origin to rotate. The .dwg WESTERN ELEVATION disappears as soon as I hit orbit or zoom. Only the western elevation is on. Why are all the imported files disappearing when I use zoom or any of it’s context menu members?
I’ll probably use edit component but will look for a reply. Thanks in advance.


#2

It sounds like you have a small piece of geometry a long way from the origin. Edit-unhide all and also make sure that all your layers are visible. Ctrl-A to select everything then deselect the geometry you want to keep then press delete which should rid you of any unwanted geometry.

If that doesn’t fix it then post the model. 99 times out of 100 this type of thing has a simple fix.


#3

Thanks Ken. I’m on it.


#4

All layers are on. I’ve tried every view and only the STREET MAP layer shows up moved from the origin position . Trying Extant zoom?


#5

Zoomed extant zoomed in to the street map. I’m guessing that there are no other objects outside of that area?


#6

Axis issue?..


#7

Ok. X is the Red Axis
Y is the Green Axis
Z is the Blue Axis
Not sure that that is the original axis orientation but the images where in their original position.
They still disappear when ever I use any of the zoom methods?
I had to use the layer tool and outliner tool & edit-unhide-all tool to see them all from top view when their all on.
When I use Camera-standardviews-iso the images disappear? When I am in ISO view I can turn off the layers and select the outliner objects that I want hidden and then use Edit-Component and that unhidden object gets the bounding box. No image even if I zoom in. Maybe, unhide selected?


#8

If you’re in parallel projection view and it is a large model parts of it can disappear when orbiting. Perspective view shouldn’t do this when orbiting. If that doesn’t fix it then if you post the model it would be easier to see the problem.


#9

Sorry Ken. Just lost the original AutoCAD file. Even Dropbox aint got it. Have to recover it. AutoCAD 360 might have a copy On THE BOUNCE.


#10

Finally got it going last night. Restored the original .DWG, Wblocked single layer plans & Elevations, set at 1/16" on layer 0.
and imported into new SketchUp model set at the same.

Turned out that the hide in edit tool was not as good as the layer control and that you should have all layers that are not involved turned off, visibility unchecked and the right layer turned on. Otherwise you are selecting hidden elements when grouping etc. A real pain. I’m a little upset that the layer objects don’t take on their color and that the edge color tool has to be set on every entity to see the difference. The layer color should suffice and then be changeable by object/entity.

Now I’m having problems extruding walls as solids and wondering if I should explode the .DWG floor plans to extrude their wall components to levels refrenced from the Elevations/Sections?

Every wall I traced/ only the exterior so far are extruding/push-pull as non solids and I’m not prepared to accept that if I don’t have to. The mouse manipulation is the problem. Using Camera-Standard Views (or icons)-Top and Zoom-Window seems to make it easier then Camera-Standard views-ISO or icon followed by Previous View icon.
Using the mouse I 'd prefer there was a right click context menu with a dropdown menu for all the menus?


#11

If you go to window-layers then click the small arrow at the top right you can colour by layer. Then in styles colour by material.

You should draw everything on layer 0. Layers should be used for visibility of components. Sometimes it is easier to just trace an imported DWG depending on how well it is drawn in CAD,

A useful extension is Face Creator however which you can run on imported geometry:
https://extensions.sketchup.com/en/content/eneroth-face-creator


#12

Thanks Ken. Drawing every thing on layer0 was a hard lesson to learn. I got this several times and had to move entities and redo them on several layers. The layer0 should be stressed more in the tutorials. Now I’ve had a push-pull limit set in the tool-tip no error and can’t see what is constraining the push-pull in any layer. Every thing seems aligned correctly but there has to be a constraint or something that is stopping the push-pull. I couldn’t capture the push-pull limit but it’s there and there is nothing about it in the forum. Anyway to turn off constraints?

Finally figured out that pressing Ctrl button allows you to push-pull past offset constraint/limit and still haven’t determined how the limit was set.


#13

Heinz
Is it possible to post your problematic skip model now?
Most program models have 6 clipping planes which are used to limit the rendering load on the graphics processor. IE top / bottom; left/right, and front/ back. Out side the viewing frustum the view is not shown. Some programs allow you to change , but in Su it is controlled by the viewing angle. Change to perspective mode, then alt and you can change;

CAD drawings are notorious for having problems and should be cleaned before bringing into SU ,but there are some plugins to help, so at least use ThomThom’s cleanup one to clean the model especially for stray lines;

The hidden wire frame rendering in SU is not selectable so, change to that then select only model , by selection window, hide, then select all, then delete and unhide and see if that helps. Make sure you save model first.

SU controls geometry isolation by use of groups or components ( Not layers ) but, it appears you still have a problem there. One of the last steps will be to explode those to allow geometry to merge.
Just some ideas.
http://help.sketchup.com/en/article/38578


#14

Thanks mac7595, I am all over it and have realized you must be on layer0 & group or component an ENTITY before speculating a SOLID. Weird but sensible enough. Strangely not stressed in any of the video tutorials? I will post some of the screen shots but the model should be paid for first. Check my other posts and you will see it is a very specific residence of Bermudian style construction in Mexico. It was already drawn in AutoCAD 2013 & the client suggested SketchUp for importing botanical elements for 3d views. Excellent idea, If I don’t say so myself. Instead I am checking in a 30 day trial to see the proclaimed productivity vs. precision context with Autodesk products.

Ergo, on my own.


#15

Hey Guys, thanks again for every ones patience. This is the Dropbox link to my model. Thanks again guys. https://www.dropbox.com/sh/694vmmk7r7vhwxp/AAB5UHCNesocvRIsvPKzXOD5a?dl=0
Let me know if the link works.