Image trimmer question

I had the Skmtools image trimmer plugin working just a few days ago. I had to do a windows re-install from scratch, reloaded Sketchup and the Skmtool image viewer and now I can’t get it to work as it did before.

I have the attached .png file where the white is transparent. The other image shows the message that displays when I start image trimmer. It displays the message about ‘making edges files’ for about 30 seconds and then just goes back to the select tool message.

What do I need to do?

This is solved. This plugin requires Java and I hadn’t installed it yet.

Working fine now!

Can you share how to use this tool please? I loaded it into Sketchup, put a PNG of a tree over a surface, selected the tree and then ran Image Trimmer. It shows it’s processing something at the bottom of the screen for a few minutes, but then nothing changes, and it doesn’t ask me to do anything else. Thanks

You should read the instructions for the plugin.

In a nutshell:

First you must have Java installed.
Next, you insert a PNG image with transparent pixels. Insert it as an image. Do not apply it to a face.
Save the file.
Run the plugin. In the case of a tree image, it might take a long time to run through all the transparent pixels so be patient.
After it has deleted all the transparent pixels and drawn the face, you’ll get a series of prompts. Answer them and you’re good to go.

It’s a good idea to crop your image as tightly as possible to reduce the number of transparent pixels.

Actually had the same problem as you. Installed JAVA and seems to be working ok now

…Although. I can create a component fine in a new model. I saved the component, and then imported it into another new empty model. But when I try to import it into the model I’m actually using i.e. with buildings and landscapes etc, the shadow keeps reverting to a block and not the outline shape of the tree. You can see in the first photo it is my model, and it won’t apply the detailed shadow, but in the other one with the same component, it is fine Any ideas? Thanks


Perhaps you could share both the original PNG of the tree and the component you made?

Hi Dave. Just uploaded some images above. Ok, am attaching the PNG and component Sumac Tree Winter.skp (153.4 KB)

I didn’t see the screen shot before. What you’re showing looks like a graphics card issue and not a problem with the tree. Try turning off Hardware Acceleration in Preferences>OpenGL and see if you get a different result.

Turning off hidden geometry would be a good start.

1 Like

The hardware acceleration option was not checked anyway, and was greyed out. There seems to be a difference between components I pick from the library and ones I import from the harddrive. The library ones cast the correct shadow albeit the graphic on the face of the tree seems a bit messed up.

That’s odd. I just imported the SKP file you shared into my SketchUp model and copied it around a couple of times.

I’m on my phone so only guessing. You appear to have shadows face sun ticked. Could that be causing an issue.

Hey Dave and Box. Thanks for your help. It set me on the right path with the whole memory / graphics card thing. As soon as I purged unused items from the model, I was able to import the component, and it casts the correct shadows. Still need to become familiar with the difference between models from the library in the component pane on the right hand side and those from my harddrive.
Can I ask you both if you have adequate power in your computers and what ram, processor and graphics cards you have. I’m running Intel® Core ™ 2 Duo Core L9400 1.86Ghz, with 4Gb RAM and a Mobile Intel ® 45 Express Chipset Family 1291MB. It’s struggling with my 12MB model.

Thanks

I think the bottleneck for you is the graphics card and the way it handles OpenGL. I have nVidia graphics cards in both my PC and MacBook Pro. The nVidia cards have generally been recognized as doing a good job with OpenGL.