How to stop geometry from being connected?

How do I stop my surfaces from automatically connecting to each other? Trying to create a curved piece along the top here, which I want to push/pull forward

You need to be isolating you geometry into groups and components as you model.

https://help.sketchup.com/en/working-components-sketchup#introduction

1 Like

My guess is that experienced users would have keyboard shortcuts. I use A for Groups and the default G for Components. Every time you have made a discrete assembly, hit one of those. Doesn’t matter if you haven’t finished working on it, just open the Group/Component and carry on. In fact, you can now start a Group or Component by invoking the command before you have drawn anything at all. That might be a good habit to adopt as it absolutely makes sure nothing you draw will inadvertently stick to something you don’t want it to.

Some very advanced users only use Components and ignore Groups altogether. This has a number of advantages (not least in eliminating the need to think which to use) but also requires good awareness of the consequences.

1 Like

Just type the A key on keyboard to create a group, and hit the G key to create a component? That’s it?

My attempt to push/pull has resulted in the surface not closing up, but rather opening up. Can you see what I mean here? I am pretty certain that other surfaces which this shape’s pulled surface touches are already grouped as others, so not sure why this happened.

Hello G is a default keyboard for components . But A is a custom shortcut Simon defined. (A is arch by default - there is no default key for group)
For your “opening” matter , did you try holding Ctrl before push/pulling ? Did you check face orientation before push/pulling ?

1 Like

Thanks, I did try holding down CTRL before pulling, but it still did not enable the object surface to “close up”. When I drew the shape from other end and pulled it ‘forward’, that seemed to solve the problem and there were no ‘open’ surfaces.

I’m trying to copy the shape now and mirror it, and I thought I was doing this while editing the group, but apparently not, as now the mirrored shape is NOT a part of the group.

Is there a way to ‘add’ this new object into the group, or must I erase it and ensure the group is open for editing and then re-draw it? (YOu can see how the blue edges and lines are not appearing on the right hand side object)

Select what you want to put in the group (triple click on something to select everything which is connected), cut (ctrl-x), enter the group you want to put it in, edit > paste in place.
If you’re already in a group, you can explode what is grouped

1 Like

From your questions and the problems you seem to be running into it feels to me like you are working too hard and kind of spinning wheels. Maybe going back to some basics would be a good idea. Start with learn.sketchup.com and if you want some woodworking specific tutorial stuff, send me a PM.

1 Like

It is if you set A up to create a group. Like this:

Paul is right. You can change a default if you don’t use the default command and want to use the key for something more useful. I chose A because it is always right under my left hand and quick to use.

When I started using Sketchup and was not used to regularly grouping things, I tended to do a lot of drawing before going back and creating groups from the raw geometry. That really was working too hard! The experienced create groups from the get go.

1 Like

I have G and Shift-G set for Group and Component.

1 Like

On my Mac, make component defaults to G or shift-Command-G, and make group to Command-G.

Sounds like you are looking in the right direction. If you had worked with components instead of groups, you can mirror a component and only need to work on one side after that, by working inside the component.

Add the geometry to the group by “cutting” it (CTRL+X) and opening the group and pasting IN PLACE from the edit menu. Oh< I see that was already mentioned. I prefer to avoid “explode” when possible.

Thank you, I am coming back to SketchUp after a few years away from it. Feeling like it’s taking a lot for me to re-learn. Have been following the Fundamentals modules/tutorials. Is the learn.sketchup.com website different to the Fundamentals course?

It looks like you’re on a Mac. Do you know where I’d find the Preferences on a PC? I used SU a few years ago on my Mac but now am on a PC so feel like am learning some things for first time. Also, just a matter of keeping on using it everyday to get back into the groove.

I am on a Mac. However, a quick Google suggests Window>Preferences.

https://help.sketchup.com/en/sketchup/customizing-your-workspace