How to make line thick with 2d line tool

Im making a cap in that im showing stitches with 2d tool extension. (model is attach)
cloth cap.skp (1.1 MB)
1st scene u can see a line.
2nd scene u can see a good doted line.
3rd scene u can see the line beside is thick and the line i want is thin.
4th scene u can notice that the line is horizontal lay down.
5th scene u can compare the side line is thick and look like a stitch but the line i want is thin.

All the lines made are of same thickness the lay down (horizontal line) and the vertical lines

I want that laydown or the line which is thin to be similar to the side lines thick in shape.

hope everybody understood my question :rolling_eyes:


Those dotted lines are actually basic raw geometry consisting of standard edges, and faces. So they can’t be treated as actual lines so to speak even if you wanted.

But things are a little worse than that. Because this plug-ins whole goal is to very cleverly bypass one of SketchUp’s huge and persistent failings… That being extremely poor support for various Line Weights, and Line Types in the first place.

This clever Extension Developer has a nice work-a-round here, and I’d go back to that plugin to see if there is a way for you to rotate the orientation of the ‘line’ which is being drawn. You did after all get it to lay correctly when going across the top of the hat… the path around the backside is basically the same.

Maybe it’s worth trying to rotate the line going across the top and re-orientate it around to the back path.

If that isn’t possible, then I think you need to adopt a similar approach yourself… Draw out a stitch with the rectangle tool. and then copy it along a path. A plugin such as PathCopy could be pretty helpful here… but there are others as well which you might prefer.

OR, option B would be to rotate those that are already here by 90º. which is what I did for a few of them in the screen capture above.

shape blender also not working. Is there any extension like we have in coreldraw or illustrator (Ctrl D) repeating the same command. Once it is rotated in 90 i have just press the repeating key only.

Have you tried to reset the Axis orientation?

Maybe if you do that, so that the lower side of the cap is then set as the ground plane (x/y plane), the plugin might then lay in the stitching to your liking.

On a positive side here… now that you’re dealing with edges and faces, there might be something to be said for using the push/pull tool to add some thickness to your stitching. That would certainly help create a nice decorative topstitch look. though it’s gained at the expense of increasing the edge and face counts in your model.

it work with rectangle tool. and then copy it along a path

Alright, you have a fix.

I’m sure there are other approaches as well, possible better, quicker, or easier, and you can obviously figure out which one you think is best.

My one point of warning for this approach would be to take steps so that you don’t run into issues of Z-fighting. Don’t set your stitching on the same surface plane as the body of the hat… Doing so will set up a scenario where SketchUp won’t be able to determine which face should be displayed on top. and it will try to display both at the same time, and in the space. You’ll know it when it happens because there will be a shimmering between the two as your rotating the model around. Holding the stitching slightly above the hats plane/surface would be the solution to this.