How does Sketchup solve 2D surface collisions?

Nice having you here. In the following sketch a blue quadrangle is moved into a white area. Blue ceases to exist in our realm of vision. Interesting. Is there a way to manipulate this chain of events without thickening or offsetting?

Those workarounds do introduce new complications downstream. As far as I can tell the layering is a function of time of creation. A younger object is projected over an older one.

Are you using groups or components?

The only way to isolate geometry in SketchUp is by grouping or making a component. Then you can move things easier.

But you will still have Z fighting - essentially 2 surfaces trying to occupy the same space.

1 Like

Grouping indeed has an effect: When ungrouped, the smaller object is always inserted inside a bigger / the biggest object and cut off on lines. When grouped the shown effect of area invisibility occurs. Componenting has no further effect.

There seems to be no active z fighting when ungrouped, instead one winner is chosen.
There is z fighting when grouped.


There is no “layering”. Sketchup is a 3D environment, not a 2D program like photoshop or illustrator. Nothing is above or below anything else regardless of it’s order of creation. Nothing is projected on top of anything else unless it is physically higher in the Z direction. If you start with raw geometry (ungrouped) rectangles and move one into the same plane as the other the geometry will merge and the smaller rectangle will become imbedded and part of the larger rectangle. In this case there is no Z-fighting because there are not 2 rectangles any more, just one plane with edges in it.
If you start with one rectangle grouped so it’s geometry is effectively isolated and you move the two rectangles into the same plane, the geometries will remain separated but you will see Z-fighting between the planes indicating they are existing at exactly the same Z dimension therefore they are occupying the same space. The graphics engine cant decide which one to show “on top” because neither is above the other they are at the same Z dimension, so it shows you both.

There are no "workarounds’ for this because this is not a 2D program, this is how 3D environments work.

2 Likes

Sketchup is a 3D modeling software. You cannot do the same as with 2D modelers or drawing/image editing programs (Bring to front, Send backwards… etc. does not apply). There are no layers either. Tags (which used to be called layers) only add the visibility property to the assigned object. They do not separate drawing elements.

The thickness of the rectangles, circles etc (planar shapes) you draw is zero (infinitely small). If they are in the same plane, the rendering software cannot distinguish which one is further or further back from the point of view (camera).

It doesn’t matter when the object was made, the visibility is random, and you will see flickering if you change the distance/angle of the viewpoint.

The only “normal” option to avoid it, is to give thickness (e.g. push-pull up by blue axes) to the drawn objects (rectangle > cuboid, circle > cylinder, etc.)
If you look at them from above, in a parallel view, they will look like planar shapes.

2 Likes

Another possibility is to create 2d shapes as components with the “cut opening” property so they can be placed on a face without z-fighting.

2 Likes

Yepp, good option, however In this case, where more object is overlapping just a partial solution: :innocent:
image

1 Like

Another possibility is to create 2d shapes as components with the “cut opening” property so they can be placed on a face without z-fighting.

Fantastic, it makes the grouped object visible. Even without z fighting.


Thank you all very much for extending this thread. :100: It was quite unexpected to receive such prompt reactions. It makes me very confident in changing to this software. It seems to be far less bloated, very efficient.