How can I fix the hole in this model


#1

I designed and printed a model and it was fine… But over the weeks I have been refining it and put a “bevel” on the top (Using Fredo66s RoundCorner tool)… I then noticed that the very top layer was not attached when printed and could be pealed off but thought this was just a quirk of my printer when creating such a fine top layer…

But today, I looked at the layer view in CURA and found that Layer45 is empty.

So I went back to Sketckup and used “Sold Inspector2” which fixed 22 faces… But the problem remains and now in Sketchup I can see an open line on the concave face.

How do I go about fixing this? Are there any tools that will let me fill the gap?

The STL is attached and I am greatful for anyones help.

26. FINAL - 1mm higher.skp (1.4 MB)

Jon


#2

How did you create this extrusion in the first place? There are reversed faces and a bunch of extra faces.


Check the attached file and see if that will behave for you.
26. FINAL - 1mm higher.skp (209.9 KB)
I also purged a bunch of unused junk from the file so it is considerable lighter than it was.


#3

I don’t know how it all got like this… I am a novice so its no surprise its a bit of a mess… But I started to notice these things creep in when I used the “RoundCorner” tool.

I will take a look at yours (thanks for fixing it)… But I only have 2016 installed at the moment, so will have to put 17 on later.

I created it by drawing a cross section and then using the Follow tool around a circle… It was fine until I started to use the RoundCorner tool.

How exactly do you “purge” the junk and fix this kind of thing… Thats what I am looking to learn… Are there any tools that help?


#4

Sorry. Here’s a 16 version.
26. FINAL - 1mm higher.skp (194.0 KB)

I guess I would have approached drawing this differently. I would have draw the end profile with the rounded corners and used Follow Me to extrude it. Fewer steps and less likely to develop problems.

As for purging the junk, go to Window>Model Info>Statistics and click the Purge Unused button.

26. FINAL 2nd.skp (192.0 KB)
Open this file and try the following. Do the steps exactly as I wrote them.

  1. Scale the right hand copy of the profile and path component up by a factor of 100.
  2. Zoom Extents so you can see the larger copy.
  3. Open the large component for editing.
  4. Select the path. (The curve running away from the profile.)
  5. Get the Follow Me tool and click on the profile face.
  6. IF the faces are reversed (that is blue to the outside), select the faces, right click and choose Reverse faces.
  7. When the Follow Me operation has completed, hit the Space Bar for the Select tool.
  8. Click in space to exit Component Edit. or right click and choose Close component.
  9. Select the large copy of the component.
  10. Hit Delete.
  11. Hit Zoom Extents to return to the original copy of the component.

You should have a solid component when you are finished. The reason for scaling up the copy is that the curves have many short segments which will create problems if you try to extrude at normal size.


#5

That is awesome… Looks great. A HUGE thanks for that!

With hindsight, i would have done the bevelling first in 2D and to be honest, I can’t remember why I didn’t…

Thanks for the purge tip… Will look at that… Whilst the model was a mess… The only bit which was causing the problem was the bit at the very top… How did you go about fixing it? I was thinking I might cut the top off… Push the curve back up… And try “RoundCorner” again… How did you do it…


#6

I just edited my previous post. Check it out.

All I did was select the extra faces and delete them. Then I softened the edges.

I expect if you had cut off the top and ran Round Corner again, you would have recreated the problems.


#7

Saw your guide above… A huge thanks for writing that… I am going to follow it through… Just cleaning up my models now as the file I sent you was the basis of many different versions (different heights and quantities) and I need to recreate all my SKPs and make sure I get rid of the bad ones…

Thanks again… I do love this forum :slight_smile:


#8

FWIW, if you just need to change the height of the extrusion, you can turn on Hidden Geometry in the View menu, select the edges and faces that need to move and use the Move tool.



#9

Oh yes… I ment to say… The reversed faces happened when I used “Solid Inspector 2”… Before that, everything was “white” but it thought they were wrong and reversed them and I never understood why or how to fix it.


#10

Hi Dave… .Thanks again for your help… I finally got chance to look at your guide and can see that rather tahn fixing it, you entirly “deconstructed it” and started again… Which is actually something that I should have thought of, but overlooked it.

I tried what you said and it worked perfectly… So I went back to my original model to see if I could entirely recreate what you did…

I deleted all of the geometry leaving a flat 2D face at one end, and a ‘curve’ that I was going to use to follow… and it was identical to yours execpt one thing… In your example, one click on the curve highlights it… WHere as in mine, I have to select little sections of it.

How exactly did you make the curve a single entity? And why is mine a lot of little bits joined together?

Jon


#11

I used TIG-Weld to weld the little short edges together. It’s available from the Sketchucation Extension Store.

When you run Follow Me, the profile edges get exploded. If you were to use that profile again, you get a whole mess of visible edges from the vertices. Those edges could be softened after the extrusion but if you weld the edges together first, you don’t need to do the softening step.


#12

Ahha… That makes sense… I already fixed it with another tool, but just wondered how you did it… I am clear now… Thanks.


#13

Sorry to be a pain but I have 2 more questions…

  1. In the version you gave me above, there were 2 drawings on the same page… I thought they were just copies, but I noticed that as I modify one the other changes too… How do you create this kind of “mirror” object, and what exactly is it for? I assume its so you can work on objects at 2 scales at the same time but thats just a guess.

  2. When I take your version and use the follow tool, I get a lovely smooth object

But when I take my original “broken” one and remove all the geometry and them do the same ‘follow’ steps, mine looks the same, but I have lots of extra geometry…

What am I doing differently to you?

Jon


#14

When the curves in the profile are not welded into a single arc but left as a series of individual edges, you get a visible edge as each of them follows the path. The same edges are present in Dave’s, but because the curves were welded together the edges are softened, producing the illusion of a smooth surface. You can soften your edges after the fact using the eraser tool while pressing ctrl or via the soften-smooth edges context menu item.


#15

I made a component of the first profile and arc. Then I copied it. There are a number of reasons to use components instead of groups. One of them is that editing one instance makes the same change to the rest of the instances in the model.

Did you follow the steps I outlined in the post? The reason it works is because I made a component and copied it. It won’t work with groups or ungrouped geometry.

So evidently you didn’t weld the edges after all. This is what I was referring to when I wrote:


#16

I did weld the edges, but only the CURVE… Never thoguht about the actual face… I get it now and can see whats wrong…

When I click the edges of the 2D shape, on yours I select the whole thing… On mine, I just select little bits of it (just like the Curve did before I welded it)… So I just need to weld it too… Got it!

It all makes sense now.

With regards to the ‘component’… I did follow your steps exactly… But I didn’t really understand why there were 2 versions of the drawing and why one changed as I modified the other…

I understand now, that they are simply the same “component”…

Many thanks…


#17

I am going to outstay my welcome… I STILL havn’t cracked it…

So after Tig Welding the 2D shape, I only maned to join 1/2 the lines together:

And when I follow, i get an extra line at the joint… But worse, I don’t get any lines on the square edges on the convex side of the model…

Any thoughts?


#18

So you welded edges together that shouldn’t be welded–the sharp corners and some how missed the connecting all the edges over the top. I selected only the inverted U shape and ran Weld on them. Then I selected the left hand vertical edge, the large arc and the horizontal edge connected to it and welded them together.

At this point you could select all of the geometry, right click and choose Soften/Smooth and that would take care of things. As a learning exercise, I would suggest redoing it and just welding those edges together that you want welded.


#19

Ahhha… I got a bit carried away and welded the whole 2D shape… What you said makes sense and now I have gone back I can see that your 2D shape isn’t 1 perimeter after all… So I rewound, and just welded the ‘curves’… And now the follow looks like this:

Great success… Finally got there…

Many thanks for your help with this… I have learned a ton in this exercise.

Jon


#20

Okay, I gave it go using MakePrintable’s Sketchup extension. It removed all flipped faces, and make it manifold. Check the picture for details.

26__final_fixed_by_makeprintable.stl (885.0 KB)