Going Plane Crazy

textures
advice
coplanar
z-fighting

#1

Hi, I’m an experienced SKP user who’s new to user forums and the Community. I’m going plane crazy and need help! I’m hoping you’ve have experienced my coplanar issue, and have a solution. I’ts affecting my ability to get designs drawn in a cost effective timely manner. I apply materials like brick stucco and wood to a single wall plane. To do this, I start by drawing lines that divide a wall plane into separate areas for applying materials. But, when drawing a divider line or rectangle, a new coplanar plane appears and applying materials to these multiple planes isn’t allowed. Undoing and taking care to verify SKP says new points are attaching to the existing plane’s geometry doesn’t help. If original plane has a material when second plane with default material is created it shimmers. Workaround #1 - Draw divider lines and let SKP create the superimposed coplanar plane or planes, and then click over them. SKP will choose one which can then be deleted. If more than two planes are created, I keep clicking and deleting till all are gone, and then I undo last delete to get the last plane back. Then I enter my preferred wall a material to the one remaining plane. If this doesn’t work, I use Workaround #2 - Rather than divide plane by drawing lines or rectangles, I divide the plane by using copied lines from the existing plane’s perimeter, and trim these lines to create shape needed for the materials. SKP recognizes these lines as coplanar and won’t create duplicate planes. Workaround #3 - Sometimes I can divide up the pesky coplanar planes into smaller coplanar areas, and if lucky, one of the newly subdivided areas will switch back to a single plane. When this happens, I move the perimeter points of the smaller single plane area out to the original multi plane area. Sometimes this works, and sometimes the multiple planes pop right back. Workaround #4 - Turn on hidden geometry to find if SKP has divided single plane into multiple hidden triangles. If so, I erase hidden lines and most of the time the original plane will remain intact and then I can repeat a workaround. But, sometimes two or three of these hidden lines cannot be deleted without destroying planar geometry because hidden within these lines will be two tiny non-coplanar triangles. This is fixable too, but requires a college degree in geometry, beedy nearsighted eyes to see in close, and of course time. There are other techniques but they all take time that shouldn’t be required. Related info that may have a bearing on this - “Something minor is messed up in your model” message happens way too often. I usually find SKP’s fix is to find and divide single planes up into multiple hidden line triangles. On a new SKP file, it doesn’t take me many commands before the “Something minor is messed up in your model” message shows up. I don’t remember seeing this message showing up nearly as much with SKP versions earlier than 2014. Related Info #2 - When removing a dividing line separating different materials. SKP is now selecting the smaller area’s material to expand into the larger materials area rather than the larger areas material taking over or its replacing both materials with the default material.All of this requires redoing work already done and saps my productivity. I fear the culprit is my laptop not crunching numbers like it should. However, 2017’s CheckUp says my laptop is compatible for 2017. Still using 2016 though. My operating system is Windows 2010 Home 64 bit. I’m really looking forward receiving thoughts to help me prevent these multiple coplanar planes from being created. Any ideas on this, no matter how plain, or how crazy they may sound, will be appreciated. Thanks


#2

This should all be fine if you draw the new edge in the same entities context as the face you are dividing.

You do not want to use the rectangle as it will not divide the existing face. If coplanar faces are both painted with a material, then z-fighting will occur by the texture renderer. (If the face absolutly must be coplanar and one on top of the other, then the one on top must be separated by at least the min of SketchUp’s internal tolerance, which is 0.001 inch. All internal dimensions in SketchUp are in inches.)

Texture Z-fighting.


I cant read anymore of your post. Please edit and divide it into proper paragraphs. (I keep losing my place in it. Very hard to read. Help us help you, by helping us in the readability dept.)

Please read the forum guidelines: http://forums.sketchup.com/guidelines


#3

Every time I divide an existing plane with a new line, it creates coplanar surfaces as GVB has explained.

It won’t happen if I divide the plane with an existing perimeter line.

Does anyone know if it’s because the file is corrupted by any of the downloaded blocks from the warehouse or because I’ve loaded multiple CAD files….

I’m using the PRO 2016 Sketchup.

Many thanks


#4

Uploading an example will help us all.


#5

screenrecorderproject1.avi (2.7 MB)

Please let me know if there’s any further information you would find useful.


#6

0mz4r-xim1a Tjis is the same video I’ve uploaded befor as gif.


#7

How about sharing the SKP file that shows that problem.


#8

DM275.skp (1.2 MB)

I had to delete most of the model to upload it here and now the problem is not happening everywhere as before, but you’ll see that is still occurring on some planes.

Thank you for your time and help.


#9

I see some places where you have Z-fighting (the flickering face thing) due to several faces trying to share the same space. I also see that edges that I would expect to have the same X and Z coordinates, don’t. For example:

The vertical line below the middle intersection isn’t on plane with the others. I expect much of that is due to having Length Snapping enabled.

When you get the endpoints all on the same plane, it is possible to draw an edge to divide the face properly.

Disabling Length Snapping and increasing Precision will help you make a cleaner, easier to work with model.


#10

Many thanks DaveR! I’ll do as you suggest… :+1: