Generating smooth surfaces from contours


#1

I’m trying to draw large and complex ditches in Sketchup so that I can easily calculate their overall volume. I’m using technical drawings of the ditches to inform my 3D models.

I am trying to use contours to construct the ditches in Sketchup. I first the trace the ditch outline from a ground plan in Adobe Illustrator. This gives me an accurate outline of the footprint of the ditch. Using the offset tool, I take the outline of the ditch and create another edge set inside slightly (say 1m). I then drop this down 5m to give me an angled profile. I repeat this process as many times as is necessary.

Using this technique I can control the profile of the ditch quite accurately, which is important as I’m interested in calculating the volume of the ditch.

Once I’ve constructed my wireframe of the ditch I use either the Sandbox ‘from contours’ tool or the TopoShaper plugin to generate a surface mesh. It’s then quite simple to generate a solid shape from the surface and obtain its volume from the entity info panel.

However I am running into a problem when the surface meshes are generated (see image). Triangular ‘ridges’ are often generated running down the inside of the ditch which looks unsightly and affect the overall voume of the ditch. This happens especially with round-bottomed ditches. I’ve tried using the smooth / soften edges settings to remove them but to no avail. Does anyone have any suggestions?


#2

I have heard of a Nudge tool or plugin. (But you would be doing a lot of “nudging”.)


#3

I’m a bit confused, is it just a visual issue,
try View/Edge Style and untick Profiles.
this will remove the thick visual edges.


#4

SU’s Sandbox - From Contours tool may skip over certain vertices within a set of contour lines when the ‘grade’ they depict is nearly vertical.
The result is the “triangular ridges” in the image you shared.

We could better understand the problem if you’ll share a model of the contours just prior to running the Sandbox - From Contours tool.


#5

Thanks for the replies thus far. I will look into the Nudge tool.

To be clear, no, it is not a visual issue and turning off viewing profiles in the View/Edge style does not solve it.

The problem is that when a surface is generated from my contours a ‘zig-zagging’ ridge is introduced along some parts of the ditch. This means the volume calculations will be inaccurate. I’ve attached another image with the problematic bits of the ditch surfaces selected in blue.


#6

Images don’t help us much here.
Attach the file in the state just prior to running From Contours.


#7

OK - here is a file with the contours and generated surface. You can see that in one of the ditch sections the zig-zagging is very bad.

Ditch iso.skp (599.6 KB)


#8

I would try to start with curviloft (Fredo6) and continue from there …