Generate report error..Help required


#1

image


#2

Checking


#3

We can’t repro on first try, but I’m remote and guys in office are Mac so far


#4

I tried 2016 on Win10 and it worked. Any particular files or platforms or versions?


#5

Su 2018 pro, win 7


#6

I’m on vacation with only Win10, which works on 2016 as well. Make sure IE is updated to 11, but even given that, we’re ending support for IE 11.


#7

Ignore that, duh - I’m on vacation: 2018 is Chromium. So that’s not it.


#8

The report worked last Friday, 29.6 … but on Monday I can not finish my design. I use a report tool much. I hope the solution will soon


#9

Is the fact that it’s labeled as a JavaScript Alert a clue?


#10

I am having this exact error today. Has anyone had this same problem and or knows the solution?


#11

@Barry Sorry to interrupt your vacation, but I have a handful of tickets over the last 4 days, all reporting the same error, and some are from our resellers in Europe. At least one user is on Mac. It’s working fine on my Mac, though. One user said he cleared his cache and cookies and it’s still happening.


I made a bug report about it: SU-39854
I’ll link this thread into the bug report.
Barry, what kind of information should I ask from the users who sent in tickets to find the common denominator? This clearly isn’t an OS issue.


#12

Same error here. I have created a short screencast if it helps.


#13

The timing of this isn’t great, because our offices are shut down this week for the 4th of July, so I can’t contact the developers. I’m collecting as much info as possible on this, for now.
I think these images from other users are good clues. Perhaps this is a 3DWH error? Maybe something to do with browser security settings?
20180704%20generate%20report%20martha%20javascript%20error

20180704%20javascript%20exception%20list


#14

I have a hunch, since my Generate Report is working fine and a few cases have definitely been from the EU.
For anyone affected, what countries are you in?


#15

Australia


#16

Do they use specific 3D warehouse items, which triggers servers searching for incoming products, due to America’s recent embargo policy with Aluminum?

imagehttps://i.gifer.com/BwlG.gif


#17

Minnesota


#18

@mthrongard That ends my theory, then. I wondered if maybe internet security suddenly got higher for browsers for some areas (like the EU and British Commonwealth), resulting in security blocking of the internet access for Generate Report. I’m definitely stabbing in the dark, though. I’ll try to contact someone today about this.


#19

FWIW, I’m in Minnesota, too. I just tried it a few minutes ago and Generate Report works fine for me. I wonder what’s different.

Since that error message indicates a “JavaScript Alert” could it have something to do with JavaScript? Maybe those who are having problems need to update or is it possible there’s a security setting that is preventing it from running properly?


#20

Whoever is affected, what are your OS versions, please? ( @DaveR, too, for contrast)