Flextools Component Finder

For some reason, when I open the free Flextool Component Finder app, it doesn’t show all the components in a particular folder. I’ve tried rescaning the tab, “x” ing out of the tab and re-opening the component folder, but still it doesn’t show all the models in that folder. They are all .skp models and appear in the Windows Explorer as being in the folder. But, Component Finder doesn’t find them. Any advice?


Better to ping @Yoni

Please explain. Thanks.

He sent an alert to the extension developer.


It is possible that some of the file names include none UTF-8 characters which could cause some problems.

  1. Check if renaming any of the files to regular english charcaters helps. Make sure to refresh the folder to see any changes (little recycle icon)

  2. Open the console. go to Extensions > Developer > Ruby Console and check if any errors come up when you load a folder into Component Finder.

  3. Send any log files you find at: C:\Users\%USERNAME%\AppData\Local\F3d_FlexTools\logs to: Contact – FlexTools

Last evening, I closed out all the existing tabs that were open, then re-added them. That time it worked and all the files are showing. Thanks for your response.

Oh, glad it’s working! Was there maybe a Windows Update running in the background?

No, there wasn’t.