Fake dimensions on circle extrude?

Helllo!

I am new to Sketchup 2017 and I am trying to create a dish . The dish has to be 240 mm wide and 25mm tall, but the model does not seem to be in a good proportion, it totally look sout of proportion? I post an image here to show you that the dimensions don’t look realistic at all.

Is there a tweak to do to make it look normal? Or is it just my bad?

Thanks!

A circle is in fact a polygon by default with 24 segments, you can change that typing a different value when you choose the circle tool. For example: clic on circle tool, type 96s (s means segments but I think it’s not necessary and press return).

For a better measure I suggest to use dimensions tool, X-Ray View to find the center of the bottom side and draw not in the origin (after this is done you can move if to the origin). If the cursor doesn’t snap to the center you have first to hover one of the edges of the circle.

mytry

The vertex that you used the ‘Text’ tool on to show the coordinates X,Y,Z displays ~123,1mm for its Y value. This is almost along the green axis. I assume that the radius is 125mm, making the disk diameter 250mm. The height is 25mm. So there seems to be nothing wrong with the measurements. You may be confused by an exaggerated perspective view.

I generally work in isometric views, but it looks about the same:

image

Another way to view the ratio of the measurements:

image

I read multiple problems/questions in your post so I’m not completely sure which is your real concern…

Your disk looks oval because it is being viewed from an angle instead of square on. The camera projection is foreshortening it into an oval shape. Try it with a real coin and you will see the same thing. Use the orbit tool to change the direction you are viewing the model from and the foreshortening effect will change.

You don’t say how you created this disk, but that seems also to be a problem. The values called out by the text annotation on your image indeed don’t look right. If you calculate the corresponding radius (sqrt(x^2+y^2)) it is 130.1, not 120, which suggests to me that you didn’t use the precision measurement technique I describe below. Never rely on mouse movement and click to set a size or length unless you are using an inference snap to make it match some existing geometry.

The right way is:

  1. Activate the circle tool
  2. Click at the location where you want to have the center of the base circle, e.g. the origin
  3. Move the mouse away from that point along one of the axes, e.g. red. This will determine which way the segments in SketchUp’s approximate representation are aligned.
  4. Let go of the mouse and type the radius you want - 120 in this case - then press enter.
  5. Activate the push/pull tool
  6. Click on the face created in steps 1-4
  7. Move the cursor upward
  8. Again let go of the mouse and type 25 + enter to set the height of the extrusion.
2 Likes

Helllo Guys!

Thanks a lot! I did create the circle with the circle tool, then i used the
extrude tool to lift it up . Yes the dimensions i gave are not correct. I
really thought there was a bug, since it looks too ankward . I am going to
3d print it and I will pay some cash for it, so I hope the dimensions are
correctly proportional.

Thanks for your help . I will try to use isometric view and check for a
difference.

Have a great day!

Ramon

Hi Ramon,
If you do as @slbaumgartner suggested, the dimensions should be correct.
Isometric (either in parallel or in perspective) isn’t the best way of getting the hang of working with SketchUp. It is just one camera position that you are dealing with and may confuse you.
Try a few cubes and orbit around them in perspective view with FOV (field of view) set to 35 degrees (or upto 50 degrees). you’ll get a better feeling about how a model should be displayd to look real on screen.

1 Like

When you print this object into a physical form, SketchUp’s polygonal approximation of the true circle may become glaringly and disappointingly obvious. As mentioned by David @spawn the default polygon for a “circle” is 24 sides. That may look surprisingly good when SketchUp renders the resulting cylinder with smoothed edges between the 24 adjacent flat faces of the cylinder. But when 3D printed those flat faces will be flat - and obvious. If you want the printed object to appear and feel cylindrical then you will probably need many more edges to the circle (i.e., more flat faces to the resulting cylinder).

You might try 96 sides as Dave suggested, but for a cylinder of 240mm diameter I would actually try many more than that such as 360. The complexity won’t bother the printer or software slicer, and won’t bother SketchUp either assuming this is the only object in the .SKP model file. The more sides you use the smoother the physical cylinder will look and feel.

To get a visualization of the effect of the number of sides, you can disable SketchUp’s default smoothing of the circle so that the on-screen rendering shows the model’s true flat faces for the cylindrical surface approximation. Smoothing is what SketchUp terms the blended shading between adjacent faces. One way to do this on an existing model is to enable Hidden Geometry in the View menu, set the Face Style to Wireframe (also in the View menu), then do a drag-select from left to right across the middle wall of the cylinder. This should select the 24 (or however many) edges of the cylinder wall. In the Entity Info dialog box (displayed via the Window menu) toggle OFF the Smooth setting. Then you can set the Face Style back to Shared and disable Hidden Geometry. You will now see more of what a 3D printed version would look like. Orbit around the model to see it from various angles.

(Leave the Soften control ON in Entity Info, which is what SketchUp uses to determine whether the edges are invisible or have a visible line drawn for them.)

1 Like

@TDahl makes a good point. The minimum number of segments can be calculated with a formula, but there’s a simple plugin to do that for you. For a 120mm radius, it gives this:

image

The " Tolerance" value indicates that the maximum deviation from a true circle to the flat is no more than 0.025mm (which is well below the tolerance of the 3D printer). The suggested value of 156 will include the four cardinal points.

The plugin can be downloaded from here:

https://sites.google.com/site/spirixcode/code/jrh_n_calc.rbz

2 Likes

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.