Exporting to DAE and keep the meter scale of measurement

Hello, I know this topic was discussed back in 2018 but did not see a resolution to the scale in meters issue when exporting to a .dae format. I chose a construction template which uses meters, and made sure the “Model Info” was using the only meter option (decimal option). The file is imported into Ubisense but the scale is not even close as the same meter measurements I see in Sketchup.
So my question is what exactly is the process I need to follow in Sketchup so when I export to .dae, the meter measurements remain? Is there some conversion ratio I need to use? I read that meters turned into inches on export?
thanks much for any help, greatly appreciate it.

I think you need to set the units to match in the importing software

I’m not seeing that meters turn into inches in the export. A DAE file export from SketchUp imports as expected for me.

This was (or still is) an issue.

Reported (Technical Problems category) in March of 2015, thread reopened February 2016.
(Help article links posted by former forum manager no longer valid.)

Reported in May of 2016 (Technical Problems category), with not much acknowledgement of the issue …

Jim Hamilton gives an example where the 1 meter diameter sphere comes out as a 1 inch diameter sphere in DAE export. (May of 2016)

Again reported (Technical Problems category) in Nov of 2016. Two SketchUp employees in the thread. …

Again reported in January of 2017 …

I thought I was involved in a topic discussing a plugin that would correct DAE files after export, … but cannot find it now. (Might have been either a private thread or is over at SketchUcation.)

I must be doing it wrong, then.

Thanks for your response Dave and Dan.

  • I am using the Construction template, I have set the Units (in “Windows tab > Model Info ) to Decimal meters, and the precision is set at 0.00000. All the check boxes in that window
    are unchecked.

  • In the Camera tab, I have selected “Parallel Projection”, and the standard view set to “Top”

  • I measured the model at 84.06522 m by 78.77723 m

I export the model as a .dae file which gets imported into Ubisense.

Once imported, the model was 39.37x larger

So 3101.605m by 3309.654m

In Ubisense, the model can be scaled down however, the issue is that is shouldn’t need to be.

I tried to reduce the model in Sketchup by roughly 39% but the scale is still off and coming in larger.

I am trying to achieve a 1 to 1 scale from Sketchup to Ubisense using the common meter measurement.

Hoping there is a setting I am missing or something to get this process to a “uniform scaling between the two apps”.

Love to hear any additional suggestions.

Christine Moore


Any chance you can export it in inches and convert it to metric in the target program(s)?

Hi there, yes we did try that method however, I believe the customer had an issue with how the model came into Ubisense.

Will run another test with the customer and see what he thinks.

Thanks much

Christine Moore



To follow-up on this item, we were provided a process from Ubisense support to follow when importing the .dae from Sketchup into Ubisense. Looks like that process will work. There is still not a 1 to 1 measurement between the two apps, but at least we can get where we need to be. Thanks everyone for all the ideas and thoughts. Always nice to know support is there for the users.

Mornin’ Christine,

Ran my own “experiment” (even though I don’t use converted files at this time) and found that when I converted a SU file to DAE and then re-opened that file in SU, it presented well. Then, saving THAT file to DAE again and re-opening in
SU again caused major data anomaly. (Did not try changing from inches to metric so that had no influence.)

No surprise that “import/export” exercises aren’t perfect. . . .

Thanks for your response to my comments and best wishes to our fellow SU user.