Exporting to COLLADA(.dae) format in millimeters?

units
dae
export
collada

#1

After much hair pulling, I realized why the units of my dae exported from Sketchup were showing the wrong units in MonoGame and Jitter Physics Engine.
It appears Sketchup is exporting in inches, despite the fact I have units set to millimeters in Sketchup.

Is it possible to change this behavior?
I must have units in millimeters so MonoGame and Jitter Physics Engine can compute inertia in the appropriate units (among other reasons).

It is troubled because floating point rounding errors due to unit conversion from millimeter to inches is large.

SketchUp Make 2017 on mac osx 10.11


Linux version of the SketchUp C SDK?
#2

SketchUp always internally captures all positions in inches. The setting in Model Info->Units only affects display in the GUI. Unfortunately, it doesn’t seem that the Collada exporter offers an option to convert to displayed units during export :anguished:


#3

FYI, This what the top of the DAE (XML) file will look like:

Manually editing the <unit> element attributes will not help, as all the exported floats
(re geometry) will be in inches (excluding <color> and <transparency> elements.)