Drape coplanar

Hi Can anybody explain why Drape does not create a coplanar line when a non coplanar line is draped on to a flat plane? Surely this is the one thing that it must get right?
This software drives me nuts!

One reason might be that there is (are) hidden line(s) in the so called flat plane.
Turn on visibility of hidden geometry.

Thanks for getting back to me. It is a rectangle drawn in the Z-plane using the rectangle tool so no hidden lines.

Sketchup does have an annoying habit of not breaking a face when it should. It has been this way from time immemorial and will probably out live all users.
There are various ways of helping it along.
Selecting the parts you want and using intersect faces with…
Using a variety of weld extensions that can make the break work
Drawing over a segment
Drawing an edge to the side
Holding your tongue the right way
one of which are guaranteed to work every time.

There is a specific one that is well known that has been named the Bowtie bug, which is basically when a face within another face connects at only one point, easily reproduced by drawing a triangle that touches one point to the edge of a rectangle.

Having said all that, sometimes your model is just wrong, as @Wo3Dan mentioned, hidden geometry can be a problem, often saved within a template. Another is length snapping being turned on which can cause tiny error, or imported cad files having their own issues.

Thanks Box.
I have tried drawing over the segment - didn’t work. Never tried drawing an edge to the side so I will give it a try.
It is really poor that the worst tools in Sketchup are those that are developed by Trimble. Isn’t it about time that they sorted this stuff out?
I have found an extension called SuperDrape but it has a habit of crashing.

Not so. This one has been an issue from day one. I also don’t agree with the comment in general.