Construction lines on back side of imported baseline image

I’ve imported a rough JPEG house plan into SketchUp Shop. I’ve exploded it and made it a group. For some reason the inference lines and axis lines are on the back side of the plan. When I draw a line, I have no idea if it is on axis until the second click. When I use the tape measure or protractor I can see the construction lines peeking out from behind my house plan image, but I only have the meter at the bottom right to tell me if I am on axis. This appears to be some kind of bug in the program because some construction lines will occasionally appear if zoom in with the scroll key. Also, portions of the drawing I’ve made will disappear when I close a face. The program is almost unusable the way it is.

Why explode it and make a group? That’s just a couple of unneeded steps.

Did you make sure the image is on the ground plane?

Share the .skp file and the image.

That process was outlined in a SketchUp Essentials YouTube video “Floor Plans from Images in SketchUp Free.”
I have no idea where the image is. I can’t find any thorough explanation of this process. I usually end up Selecting and Grouping until I get an image I can draw on.
I do have SketchUp Shop because I wanted to support a company that offers such a helpful program. I just admit that I barely know how to use it. Is there a book which will describe how to draw plans and make models for a non-computer-savvy user? A<div da
Pinwheel House1.skp (5.6 MB)

Add multiple images

dd multiple images

OK. Seems like a strange thing to me to explode and image and then convert it to a group when you can leave it as an image and draw over it. That also leave it visible when editing components or groups. Here I’ve left the one on the left as an image and the one on the right is a group after exploding the image.

Exploding the image converts the image to a texture and you wind up with a textured face in a group.

As for your guidelines not showing up it could be that the image is above the ground plane a little and your guides are on or under the ground plane. It might also be a graphics card thing.

Here I’ve added some guidelines over my image and group. They show fine for me.

I see you added your model while I was typing the above. I’ll take a look.

I see the guides in your file. Lots of them!

Do you have Guides turned on in the Display panel?

What browser are you using?

As for your question about books, I’m not sure there are any on modeling houses in SketchUp Shop. There are some books aimed at using SketchUp for Architecture but all pointed at SketchUp Pro users. Still they could be helpful. Might look at Store -

Thank you for your reply, Dave.
What is happening is: previously when drawing a line, I would see a red, green, or pink line after the initial click and I move the cursor. These aren’t showing up now. When using the tape measure, the construction line would appear right after the first click and I could move it to the required distance from origin, now I am not seeing it until I make the second final click. I am also not seeing the protractor or make-door wheels until I draw the motion using the measurement box at lower right for the angle, or I see the “quarter circle” message appear.
My Display panel looks just like yours. Guides is active. Scenes is set to 2D Isometric.
Do you think I should discard this drawing and start over?

Before you discard this one just start a new file. Do you see the axis colors when using the Line tool? Do you see guidelines in the new file?

Again, what browser are you using?

Thanks again, Dave.
I’m using MS Edge. I also have Firefox but I haven’t used it with SketchUp.
I opened a new 2D drawing and everything worked normally.
Is there a way to force everything onto one plane with my old drawing?

Go back to the original, and in the camera settings, put it to perspective. See if that changes anything. Your file opened up as a parallel projection, and that can sometimes affect the visibility of overlapping geometry.

1 Like

On a side note, your kitchen and laundry room both have French doors being blocked by either a sink/counter or a washer and dryer. Could be an issue for the homeowner. :wink:

Chrome and Firefox are recommended for SketchUp.

OMP made a good suggestion. Try putting the camera in your original file into Perspective mode.

Thank You Dave and OMP,
I tried putting the image into Scenes perspective mode and the “in-progress” construction lines came back. I also tried working on it in Firefox and it worked OK.
A related issue that I have ongoing problems with is, that whenever I close a figure it makes an opaque face that I can no longer see the original drawing through. I have tried erasing or hiding the faces, but then I have great difficulty opening and healing them to get the face back when the drawing is done.

Thank you for your help.
The drawing did work better in perspective mode.
Perhaps my drawing grammar wasn’t obvious in all that mess, but those are casement windows over a half wall in the kitchen and laundry. Those Are french doors between the Dining Room and the Terrace.
Are casement windows out of date? Perhaps I am too entrenched in my Wrightisms.

Ah, no I didn’t catch the linework for the wall. Sorry about that. IMO, casement windows aren’t something that’s out of date or not, they serve a specific purpose. They do well in those two areas where reaching over a counter to open a window can be a little more challenging at times. It really depends on what the customer wants and is willing to pay for.

Also, the “issue” you’re referring to when closing a polygon is just what Sketchup does. You created linked coplanar edges, and it created a face from that. I’m not sure what you can/can’t do with Make, but one workaround would be to go to View->Face Style->Wireframe. That will turn all the faces invisible, and can easily be turned on/off.

Thanks for the Advice!

I have to say that I find the “Healing” process maddeningly unreliable and unpredictable. In some places on the drawing, I can merely divide up the greyed-out spaces, and they add a white face to the existing white face every time. In other spots, I can break and heal and divide up over and over without ever getting the program to turn them into white faces. I can’t see any reason for SketchUp’s change in behavior between different spots on the same drawing.
Is it the direction of progressive additions? Should I always work right to left? Bottom to top? I can’t figure It out.

The direction isn’t important but you do need to watch for tiny gaps, overruns, and non-coplanar edges.

You might find it helpful to edit the style to set Profiles to 1 or OFF. That can make it easier to see very short gaps and overruns.

Thanks, I’ll give that a try.

I don’t see Profiles anywhere. Remember I only have shop.
What maddens me, Is that I can get only so far healing new areas and then the the newly joined grey areas start to “pollute” my newly converted white faces when I try to join them. I can backtrack back to previously converted areas and start dividing them up again but the heal process will no longer work in places they previously did.

Yes. I remember you have Shop.

Styles: Edit.
Screenshot - 2_26_2022 , 5_53_25 PM

In Edge Settings:

Do you mean the blue back faces? Right click on them and choose Reverse Faces.

You could choose X-ray in Face Styles which would allow you to see through the faces, too.