Can't load Extensions in Sketchup 2016

I’m running 2016 and when I go to the Extension warehouse it asked by to login. When I login it says “Authentication Error” - “Something went wrong during the authentication processs. Please try signing in again”. I’ve tried uninstalling and reinstalling sketchup. I’ve even uninstalled IE11 as well as delete all my history and cache as other posts have recommended. I believe the first time I tried this I was able to login using my Google credentials but now I can’t get even get to the place where it asks me for a user name a password.

Please advise

Reported in several threads, already:

… and…

I’m on a Mac, and I’m having a similar problem, although I get no error message. I can’t download/install an extension using either a browser or the Extension Warehouse window in the SU Make app.

Still not fixed. I can sign in now, get to the plugin, start the download, some brief error message is flashed, then logged out and back to the home screen for EW.

Can you please try again? The fix was deployed mid-morning Tuesday.

Best Regards,

I still get the authentication error.

Steps to repro are:

  1. Launch SKetchup 2016 version 16.1.1449 64-bit
  2. Click on Window → Extension Warehouse
  3. A page comes up with a sign-in on the top right corner. Click on the sign-in link
  4. Page comes back blank with the error message "Authentication Error ! - Something went wrong during the authentication process. Please try signing in again


Can you login to the 3dwarehouse through it’s button? Or in a standalone web browser?


Nick, I still get the login error in extension warehouse:

Something went wrong during the authentication process. Please try signing in

But login and download works fine for 3d warehouse both inside and outside sketchup.


Yes - can now login and download through standalone web browser (IE 11) but can’t through the sketchup app

Try Brad’s suggestions here Authentication error - #6 by Rich_E.

Problems with SU2016 / win 7
what is going on, what do I do
DC components does not work properly?
Outline is not working properly …

Nick, this is working now for me through SketchUp. Thanks for the help.

I am able to go to the 3D warehouse directly from Sketchup, but the Extension Warehouse refuses to come up today. I can get to it in a browser, but I’d like it to work like before, which was great.

Same here - attached is the authentication error I get

Did you-all try Brad’s suggestions here Authentication error - #6 by Rich_E?

Ah - Brilliant. All works now. Thanks for following up with me. Very impressed with the customer service/support