Can't Export 2D images from Sketchup

I’m trying to export a 2D image from a simple Sketchup file, which I have done for years. All of a sudden it gives me an error saying I’m not authorized to save to this location. (Or any location as it turns out) I running Windows 11 with the latest version of Sketchup Pro. I save the picture to a new file and tried that, I have restarted Sketchup and the computer with no luck. Any suggestions would be appreciated.
Cheers Bruce

Presumably you are saving to a local directory on your computer like My Documents? This sounds like a permissions issue on your computer. Long shot: When you installed SketchUp 2022 did you right click on the downloaded installer and use Run as administrator? You might try doing that and then choose the Repair option. Another thing to try would be a full power off reboot.

I will give that a try but I have dome most of those things already. I’ll let you know

Use the snapshot capacity of MS Windows: (Win + Shift + S); rectangle select what you want in your image (it is copied to your clipboard); open an image manipulation application (I use PaintDotNet); paste (Ctrl V). Crop as necessary.

Stuff like axis lines will then still be visible, and exporting as a .png lets you do so with a transparent background, something that’s a lot harder when using the snapshot function…

1 Like

And making screenshots only gets you screen resolution.

The 2D image export should be possible from SketchUp as long as the user is exporting to an accessible location.

Thanks gregor_sghapiro and BorgMan
I have used that method in the past but I feel I can get a better (cleaner) image when I export the image.

Did you try the things I suggested?

Where are you trying to save the exported image?

What happens if you try to export an image from LayOut?

Hi Dave
It is a file permission error. I’m try to save the image where the original SU file is located. I have tried other location with no luck. This problem seemed to arise when I did the latest version upgrade…
I did try repairing and running as admin and a full reboot but nothing has worked so far.
Unfortunately I have to go out for a couple of hours so I’ll have to give up for now.
I have no problem exporting to layout.
Thanks for your time.

And what is that location? Have you checked that folder’s Permissions?

That wasn’t my question.

It’s interesting though that exporting to LayOut works at all in this case, no?

Not really. Send to LayOut is not the same as exporting a raster image to a folder.

Axis lines can be extinguished. Either in the SU application or by selecting the color in the snapshot and erasing or filling with the background color.
:magic_wand: Magic wand select the background color (s) and erase…
There’s often a way.

That’s true and again, as long as you are OK with screen resolution it works. For higher resolution images a screenshot isn’t suitable and the 2D image export should be working for the OP.

In my experience a printout from Sketch Up (Make 2017) is inferior to a screenshot.

Printing from SketchUp is different from exporting an image. And the image export options have changed and been improved since SketchUp 2017 Make was released.

1 Like

Sorry Dave, I’m no familiar with exporting an image to Layout. I can send the file to Layout with no issue or insert it from Sketchup within Layout…

Not to LayOut. FROM LayOut. in LayOut, File>Export>Images…
Screenshot - 4_1_2022 , 11_21_25 AM

And for at least the third time, what folder are you trying to export the image to and where is that file located?

Can you also try to save to a different location? As in File > Export 2D image > change folder?

The export images from Layout worked fine. I can use that for my need.

As I stated in a previous response the export is going to a file in my documents. It is the same location where the Sketchup and Layout files are.