Can anyone figure what I am doing wrong with Flowify

I think I have each of these grouped properly but the staircase example and the partial dome will not Impose Grid even though the third example will.

When I click Impose Grid with the staircase example nothing happens

When I click Impose Grid on the partial dome example it seems to impose the grid on the dome not the square

Before Impose Grid


After Impose Grid

The face changes and it does give the option to Undo Impose Grid

On the third example it seems to work just fine

Here is the skp file
Untitled.skp (725.4 KB)

I just cannot figure what I am doing wrong

probably should have given you the skp without the Impose Grid
Untitled.skp (710.4 KB)

Thanks, I never thought of taking the point out. Do you have any idea why the staircase example won’t Impose Grid?

Read description for Flowify - Extension | SketchUp Extension Warehouse

even when I just welded that edge together, it still will not Impose Grid. Am I doing something else wrong?

Do not weld, draw a new line

Thanks, that worked. Do you know why welding didn’t work?

I welded the top and bottom edges to get one line each

Welding does not make a single edge out of multiple edges. It converts the edges to a curve with that many segments.

I have run across another situation where I cannot get it to Impose Grid


Untitled.skp (735.6 KB)

It seems every time there is a different thing I am missing

In this case one of the connection edges don’t connect to a corner of the target surface.

how were you able to find that, I looked for hours trying to figure out what was wrong. I still have not been able to get it to Impose Grid even after I fixed that

Nope, sorry I did it again. I cannot seem to join them lines. I will work on that

finally got it. Now just to figure how to catch those kind of mistakes

Maybe you should edit your style and set Profiles to 1 or turn them off. That’ll make it easier to spot problems like that.

Here is Profiles set to 2. The heavy edges make the bad corner difficult to see.

And set to 1, the bad corner is easily seen, at least on my screen. Maybe click on the image to see it larger.

In this case I think you are a victim of Sketchup’s inference engine. When you draw the lines Sketchup will snap to the blue axis which will not yield the correct result since the two surfaces have different widths. If you move the top group away along the red axis, it will be easier to connect the groups since the inference engine will not lock to an axis.

Aggressive zoom also helps in overriding inference engine locks…

Thanks DaveR, I think I will try changing that to 1 permanently and see if it improves my workflow.

I will try moving the pattern, I had seen that in some videos but did not realize why they were doing it.

There is some value in heavier profile edges some times although I prefer to leave them set to 1 for my modeling. Profile edges can help you identify some issues. Turning Profiles off entirely will result in a slightly faster style but that can result in some of the model disappearing. Example:

Profiles set to 1

Profiles turned off.