Axis rotate cursor keys are instead changing scenes, not axes

Mac Version 18.0.16976
Woke this morning and loaded a model I had worked on without issue yesterday.
With the rotate tool selected (q), and the mouse placed on the blue axis, I select the left cursor arrow keys to switch axes, and instead, it rotates thru the scenes. ?!

1 Like

Sounds like something similar to this thread:

Not quite. I’ve read thru that thread - I do not have old versions installed. I’ve disabled smart quotes in Mac Settings, this does not change anything. Then I start a new model with no scenes and the cursor keys change axes as expected. I then create 1 scene from this ‘virgin’ model, and the cursor keys are still behaving as expected. However, the moment I go to a model with multiple scenes, the left and right cursor/arrow keys now rotate left or right thru scenes. I think a re-install of the app might be in order, or…?

Do you have some scene manager type extension installed that could be hijacking the left and right cursor keys? Look through the keyboard shortcuts to see what Left and Right are assigned to.

It’s an Unmac thing, but have tried rebooting?

Yep - rebooted several times. I’ve got a 2018 MBP w/ SSD, it only takes about 12 seconds to reboot, Alas – No joy.

I do (did) and disabled the plugin, restarted app. No joy.
Next, I copied all the elements out of the old model (with multiple scenes), pasted into a new model. The problem disappears!
I create a virgin model with simple box geometry, create 3 scenes, again no problem, cursor now behaving as expected.
While I’m not thrilled at the prospect of having to do this with ALL my old working models, I guess that’s the workaround.
Is there an appropriate trimble bug report place I should send this to?

Since the problem seems to be associated with that particular model, can you share it so that the experts here can see if they can find anything peculiar or incorrect in it?

Most happy to.
Kiosk-Small-GrassPark.skp (5.4 MB)

And BTW - just want to give y’all a tip-o-the-hat for your super prompt responses here in the forum. I’ve never experienced such a responsive community. Deep bow of appreciation, comrades, for your professionalism and dedication to strengthening the community.


Interesting project.

I just tried the Rotate tool and locking orientation with the cursor keys and it works as expected. This was in SU2019 on a Windows machine, however.

I can’t reproduce your problem on my MBP Retina. One thing I would suggest is that you download and install the latest version of SU 2018 (18.1.1180 for Mac) as there might have been a bug fix between the version you have and the latest maintenance release.

As a side issue regarding modeling practices, you are not using SketchUp layers correctly. There are numerous edges and faces that do not use Layer0 and you have another layer active. There are also several unused components in your model that you could purge unless you will need them later.


And as I’ve just discovered - while all of the geometry, components and layers come over, the scenes do not. So, while it poses another significant inconvenience, it also provides a clue as to what’s causing the problem - something in the scenes data…perhaps…?

I will do so.

I also have no immediate issues with the model on windows.

Do you have any plugins that work with animation? Just speculating about what could cause a step to the next scene. You could try opening the scenes window and unchecking the “include in animation” box on each scene. The name of the scene will come to have parentheses around it, indicating it is excluded from animation.

@ slbaumgartner
I dont have any animation plugins, but I’ve got the LibFredo stuff installed. enabled or disabled does not seem to make diff.
I tried unchecking “include in animation” no change.
I think I am going to bite the bullet and upgrade to Skp2019, and I’ll report back later.
Again, thanks for all the timely repsonses.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.