Right Arrow Key Does Not Lock to Red Axis

Hello, ever since I installed SketchUp 2018, I’ve been having a problem where the RIGHT ARROW KEY DOES NOT LOCK to the red axis. This makes working in SketchUp next to impossible for me, since I rely on that function constantly. The Up arrow still locks to the Blue Axis, and the Left Arrow still locks to the Green axis, but I can’t get the Red axis to lock, when using the right arrow. This bothered me so much, that I have stayed in SketchUp 2017. I recently upgraded to Version 2019, and this is happening in this version, as well. I even tried to uninstall 2018 and reinstall. Am I overlooking a corrupted file somewhere?

Please help!

Have you considered that your RIGHT ARROW key might be malfunctioning?
Does it work other than in SU?
Never mind, you’ve suggested that it works in 2017.

1 Like

I am positive the Right Arrow Key is still functioning–it works correctly in the 2017 version of SketchUp. That is why I stuck with the old version for so long. Now, I just upgraded my laptop, and seem to have gotten locked out of my old 2017 version, so now I have to deal with this issue.

These strange anomalies are often a result of not installing using the Right click Run as admin method.
Find the install .exe and Right click and choose Run as Admin and select repair when given the option.

Oops, sorry doesn’t work for Mac.

1 Like

It is possible the right cursor key is being highjacked by an extension?

Or as Rick said in Casablanca, to paraphrase “We’ll always have shift”. Does using “Shift” lock your axis?

The shift key isn’t locking ANY of the directions! So frustrating.

Have you tried a cold reboot of the computer?

@DaveR You use both Windows and Mac, I’m back to Box’s answer. Improper installation. How do you do a “repair” on a Mac?

One thing that can happen on Mac is where you install a later version without quitting the earlier version, and you end up with a mixture of versions. Currently, all three of the applications should show a modified date of March 21st. If they do, they’re probably ok. If any are different, you would want to mount the DMG you had downloaded, and drag the SketchUp 2019 folder back into Applications, having made sure you had quit this time.

There isn’t an installer, that could then go wrong.

3 Likes

Not a Mac user so could be totally wrong.
People have fixed things by removing/replacing the json file, perhaps do a search on that.
2018 to 2019 is the first time they have carried any settings over from one to the other, so it could well be related.

Extensions can’t respond directly to key presses outside of a tool implemented by the extension in question. Setting up shortcuts is a manual process.

I can recall one instance in which a user intentionally set a SketchUp shortcut to use the right arrow key (a bad choice, IMHO!). I’ve never heard of it, but I suppose that could also happen due to some kind of accidental error in the preferences json file. If that happened in 2018, it would be passed forward to 2019 because new versions try to preserve your shortcuts from the previous version.

The shortcuts dialog doesn’t give a way to filter or search by key assignment. Scrolling down the list is tedious and will omit entries that are for non-active context menus. So try the following snippet in the Ruby Console:

Sketchup.get_shortcuts.find {|sc| sc.start_with?("Right")}.inspect

If a shortcut has been set to use the right arrow, this snippet will print a string starting with “Right” and following with the target command. If one is reported you can use the preferences dialog to choose a different shortcut for it. If no such shortcut has been set, the snippet will print ‘nil’.

It’s also possible to tell macOS to use the right arrow key as a system shortcut via System Preferences -> Keyboard -> Shortcuts. In that case SketchUp itself won’t ever see the keypress. I don’t know how to search the macOS shortcuts to find out whether a key has been assigned. This also seems like a more remote possibility because 2017 and other apps handle right arrow normally.

Bad installations with strange glitches are quite rare on Mac. There is no equivalent to the Windows “Run as Administrator” requirement. I’ve never encountered the issue @colin described. It would be weird for that to affect only the inference locks, I’d expect more widespread issues.

The most common issues on Mac with keyboards I know are with the ‘smart quotes’ setting in the keyboard settings.
There might be more.
There is no real ‘Run as Administrator’ on Mac, but the crucial thing is that the OS ‘knows’ that a human is acting when you physically drag the SketchUp folder in the applications folder, otherwise it will ‘quarantaine’ the installation.
This could be seen as ‘Run as Admin’ equivalent on Windows (Administrators are a special human breed):smiley:

The difference being that the action of dragging the app to the applications folder is obvious in the Mac imstaller’s gui whereas it is hidden away in a right-click menu on windows.

You don’t need to repair on a Mac. But if you have to, reinstalling is really easy.

Thank you SO much for all the responses, and help. I looked through all my shortcuts and discovered that the “Apostrophe/Quote” key was listed in the Shortcuts as “Right.” (see screenshots here: https://www.dropbox.com/sh/2f88niyc4rse97d/AACWu0AQLNfFUtCNya4M5T82a?dl=0)

Maybe this has to do with “smart quotes,” as MikeWayzovski mentioned? It seems that the 2018 & 2019 versions of SketchUp see both the"Apostrophe/Quote" key and the “Right Arrow key” as the same thing. So…I removed that shortcut, and the Right Arrow/Red Axis lock is working again!!! Eeeeeee!! So happy!

Thanks, again, everyone!

4 Likes

AFAIK, Smart Quotes is a System setting on Mac - automatically turns keyboard upright (typewriter style) single or double quotes into ‘curly quotes’ that typesetters use in printed material.

Leaving it ‘on’ really mucks up Ruby coding, and lots of other things that expect the standard quote characters - e.g. ’ for feet and " for inches.

1 Like