All my files and Apps are missing from Trimble Account

I can login to my usual Trimble account, but when I click on ‘Manage My Account’ or ‘My Apps’ I get nothing. Only a notice that SAFARI CAN’T OPEN THE PAGE, and that server unexpectedly dropped my connection. I get the same message for both actions (screen shot of message for “Manage My Account” attempt below.

I just tried it out on a Chrome and an Edge browser without any issues. I’m away from my Mac at the moment, so I can’t try out Safari. Have you tried a different browser?

What Mac OS version? Please add that to your forum profile.

What happens if you use Chrome or Firefox?

MacOS Monterey. 12.5.1

Please add that to your profile.

And what do you get if you use Chrome or Firefox?

Just tried in Chrome and same results…

See this post:

I put in a ticket with help desk yesterday. So far no response.

So you didn’t bother trying anything in the link I shared?

I tried other browsers and that didn’t work. I didn’t try your link because I don’t want to change my password. It works and I can login. It’s after I login that the account fails to talk to Sketchup Servers. Somehow the link between my account and my files has become corrupted.

Can you sign into the Trimble connect mobile? on your phone - disconnect from Wi-Fi before you do.

Adam, I Haven’t tried Trimble connect mobile, But I WAS able to sign into Trimble Connect successfully using my wife’s Chromebook - AND All my files and apps are still there and working just fine.

This means it is not a networking issue with ATT HighSpeed Fiber Internet, firewall, etc as was suggested by Sketchup Support.

However, I still cannot access Trimble Connect using my Macbook Pro with MacOS Monterey 12.5.1 with either SAFARI v 16.2 or CHROME Version 101.0.4951.41 (Official Build) (arm64) browsers.

I can’t understand what would cause the SketchUp server to drop the connection to Trimble Connect on both browsers on my Mac. Not an ad blocker. Not a firewall issue. ATT is saying it’s my MacBook Pro.

1 Like

It’s probably your Mac isn’t responding in some way and the server is then giving up on you.
It seems to be a common error message with many different fixes to try.

As it works on the Chromebook and I imagine that routes everything via google dns, it might be worth resetting your network settings and changing to another dns provider.

Delete your current Wi-Fi connection and re-add it.

Then try googleDNS or OpenDNS

Thanks. I switched to OpenDNS no problem, but that didn’t fix the SketchUp issue.

I also tried to raise my own IP address after switching and that gives me the same error - page failed to open. This
was also the case with ATT provided DNS servers.

I just tried to update my version of Safari browser, and got denied.

NOTE- Issue Resolved.

Cycled power on MBP and then was able to download the latest SAFARI browser (Ventura 16.5.1). This took 45 minutes. Cycled power after downloading new SAFARI, and then - Problem Solved!

Thanks to all for your help. Much apprecaited

1 Like

This topic was automatically closed after 91 days. New replies are no longer allowed.