Align View to ground plane - True North

That depends upon which of two methods you used to geo-located the model.
• Add Location
• Set Manual Location

I would suggest you do not use the Add Location feature to geo-locate the model.

Geo-locate the model manually.
Click … Window > Model Info > Geo-location > Advanced Settings - Set Manual Location

The Set Manual Geo-location dialog opens.
Therein:
The Country Field is merely a label.
The Location Field is merely a label.
Enter Latitude and Longitude in 6-place Decimal Degree format.


The L,Lo coordinates of a geo-located SketchUp model coincide with SU’s World Origin [0,0,0]
By default, in a manually geo-located SU model, true north coincides with the +y solid green axis.

Such is NOT the case in a model geo-located via the Add Location feature, which imports terrain geometry and imagery from Digital Globe.

When using the Add Location feature you’ll find true north rotated slightly away from the default +y solid green axis.


There are four parameters you must set to display shadows that accurately portray the real world.

• Geographic Orientation — Relationship of True North to the model.
• Geographic Location — Latitude and Longitude
• Time — Year, Month, Day, Hour and Minute
• UTC Offset — The difference between local time and the Coordinated Universal Time standard.

Check your model settings against what they should be in the real world.
You’re welcome to share the file and we’ll have a look, if you have difficulty sorting things out.


5 Likes