A disk shaped wedge


#1

Hi everyone. I’m Chris and I’m very new to sketchup. I want to learn to make small parts for use in multirotor copters. I’m trying to make a wedge that fits under the motor and tilts the motor by 5 degrees. I can make the disk with the slots for the mounting screws but I cannot for the life of me figure out how to make it a wedge shape. The closest I’ve come is by drawing a rectangle through the disk and using the intersect tool slice through the disk but this is very hard and isn’t working very well. Does anyone know of an easier way to accomplish this. This shows what I’m basically trying to make…http://www.thingiverse.com/thing:652243
Thanks in advance for your help.


Erratic behaviour of edge intersect in simple geometry
#2

To the contrary, it’s very easy and works very well:

There is no easier way to do this unless you have SU Pro.

-Gully


#3

Hey thanks Gully. Is there a tutorial or something on this technique? I’m sure I’m making it harder than it is.


#4

Gully’s approach is probably all you need.

When looking at the model you show – It looks as if it might be a rotated extrusion. You may not need that little bit of rotation. and if not then Gully’s approach is the easiest way to go.

If by chance the rotation is crucial, then in addition to the push/pull tool. I’d also use the rotate tool as well.

Basically just perform a very small extrusion, and then select the top face, so you can activate the rotate tool and get the rest of the extrusion by way of rotation.

Something similar to the screen shot below.

I have no idea if this is going to matter, but just in case…


#5

JimD thanks for this method. You know come to think of it there really does need to be some rotation because the motor will now be at a 5d angle to the face of the arm. I’ll have to play with both to figure out which has the best workflow for me. Using Gully’s method it appears that I must make both the disk and the rectangle (which must be extruded slightly to make it 3D) a group in order to make them solid. Is this correct? I really appreciate the help. I did not expect to get answers so quickly.


#6

On second look the rotate doesn’t angle the screw holes but using the move tool does allow for this.


#7

The method I demonstrated earlier, the Intersect Faces command, does not require solids to function. Hence, the rectangle does not have to have any thickness to cut the cylinder: it only needs to be a face.

If you want to create a solid, the part I demonstrated earlier would be a solid if grouped.

Finally, the piece you have depicted above is the same as the piece I demonstrated earlier only flipped over.

-Gully


#8

Gully, I’ve tried this as many ways as I can and I don’t get the same results that you do. When I cut the disk with the face, using intersect face model, and start deleting the parts I don’t want I’m left with a solid face on the bottom instead of holes that go all the way through. The circles seem to be there but I can’t select them individually. Instead it selects the entire bottom. What am I doing wrong?


#9

Are you dealing with raw geometry (edges and faces) or with groups and components? Any elements you have in a group will be isolated. If you try to erase an element that is part of a group, you’ll simply erase the entire group.

You’ll probably get conflicting advice on this point, but personally, I don’t start creating groups and components until I need to. As long as I’m doing basic geometric forming operations intended to produce a single, integral object, groups just get in the way. Everything you see in the pictures above is raw geometry; there are no groups yet. Now, once the final configuration of the object is completed and there are no additional forming operations remaining, only assembly, that’s a logical time to isolate and protect it by encasing it in a goup or component.

-Gully


Bug when cutting an object using Intersect Faces command
#10

Gully, I’m not making a group or component. I tried that but as you said it creates other issues. Here’s what I’m doing. I create the disk with the holes by making a circle and adding the holes to the 2D shape. After deleting the holes I pull the circle into a disk.


I create a rectangle and rotate it at the desired angle. I select it and move it into the disk, cutting the into a wedge. While the rectangle is still selected I right click and select “intersect faces with model”. Once this is complete I delete the parts I don’t want. the rectangle and the lower part of the disk. It looks something like this as I’m going…
Instead of the entire lower part of the disk being deleted at once I have to delete each line. When I get to where I have the wedge disk I want it has a bottom to it instead of the holes going all the way through…
When I try to select the holes to delete them I can only select the entire bottom. If I delete it I’m left with this …


#11

I can reproduce what @tr3topflyer shows and I am coming to believe it is a bug. After doing the intersection and deletions, I opened the Ruby Console and got references to the large bottom Face and the bottom Edges of one of the screw holes. I tested the start and end positions of each Edge using Face#classify_point, and in every case it returned 1: Sketchup::Face::PointInside (point is on the face, not in a hole). To me this says these Edges should have cut the large bottom Face but failed to do so. Note: this is not a size issue - I scaled up by 100 before trying this!


#12

Further evidence of a bug: I selected everything, made it a group, then exploded the group. Then I redrew one of the Edges of each screw hole, like you sometimes have to do to tell SketchUp to create a Face that it omitted. This caused the holes to cut the bottom Face the way I would have expected. The same redraw did not work before the group+explode.


#13

So could this be a workaround?

No sadly this didn’t work either.


#14

Now that you mention it, I believe I did have to trace over one segment each for the middle hole and one of the radial slots–not all of them–to get them to cut the bottom face. At no time did I group the geometry.

Okay, I just reconstructed the thing. I executed Intersect several times, observed the result, and hit Undo far enough to repeat the Intersect command. The results were inconsistent: there were always some segments that remained thick profiles and did not cut until I traced over one segment. I tried both selecting only the face and executing Intersect Faces with Model and selecting everything and using Intersect Faces with Selected. The results were about the same. Whichever method I used, if I performed a second Intersect Faces with selected, all the faces actually did intersect.

-Gully


#15

So retracing a segment worked for me and while it’s kludgy, at least it enables me to make the piece the way I want. Using rotate made it hard to keep the screw holes perpendicular to one face on which the motor would sit. This slicing method, however, does that nicely.

I sure wish the bug would be fixed but I’m very grateful to you guys for finding a work around for me. Is there a way for me to report the bug? Can I just point them to this thread?

tr3topflyer


#16

I should clarify: after tracing an Edge I had to delete the Face closing the end of the screw hole. Tracing the Edge just got Sketchup to recognize that there was a Face there.


#17

Yes, pointing to this thread should be sufficient. It is surprising nobody from the SketchUp team has picked up on this topic…


#18

Yes that is what I experienced too. But at least then I was able to delete the face covering the opening.


#19

@tr3topflyer
@slbaumgartner

Put away your bug nets … RTM
The intersection works as expected for me and it will for you too; if it’s done properly.

Intersect With Model Tool: Creating Complex Geometry — SketchUp Help
Bestow particular attention upon Step 3. Triple-click on the



#20

I read that document thoroughly before I even posted. I have done the triple click. It still doesn’t work for me. Remember the example in the document involves two 3D pieces. I’m cutting the disk with a face. If you follow the steps I outline above you will have the same experience as me.

Actually…follow the example in the document but make some holes in the box. Try to cut into the box with the tube and see what happens.