45 degree triangle diagonal not correct

I have drawn a 17’ by 17’ square in both Make and the free Web version, then when I measure the diagonal from corner to corner I get 24.5, not 24. I saw some threads on diagonals, but I have created a new file from scratch to be sure I was not drawing in multiple planes. Any idea why this is not calculating correctly?

Thanks.

Hmmm…

How about uploading your SketchUp model so we can see what you actually drew?

1 Like

Well, per Pythagoras, the right value is 17*sqrt(2) = 24.04163056…

If I set the display units to decimal and max places, I get this, which is correct to within the displayed places:

diagonal

If you can share an example model with the problem, we can no doubt tell you exactly what is wrong.

1 Like

To be sure, always measure both diagonals, at least they should be the same.
Where we live, the carpenters who built the wooden houses always used the 3-4-5 method, to check if angles are square.
Pitch’s of the roofs are also 3:4, so the slope would be 5
Calculating square roots wasn’t everybody’s favorite activities.

I am using a construction template, 2-D, and tried the online version. Here is what I am seeing:

Not sure how to post a file, just attached it.

Thanks!

Basement v1.02.skp (232 KB)

SketchUp is creating the triangle correctly. 1/2 inch is equal to 0.48 feet.

I get the same thing you get.

But when I change the display precision to show the dimension more precisely I get.

Screenshot - 1_2_2021 , 11_42_00 AM

Are you reading that dimension as twenty four and a half feet? It’s twenty four feet one half inch.

1 Like

The dimension is right.
Is your question about displaying the distance in feet+inches versus decimal feet ??

Don’t confuse feet and inches.

The value of 24.041631 feet is correct.

0.041631 feet = 0.4996 inch or 1/2 inch if you prefer.

1 Like

As @DaveR mentioned I am sure this comes down to unit setting being different in different versions of SU

One curious thing is that the trailing .4995667241114 doesn’t then put a tilde at the front. I wonder at what point it should have shown ~24’ 1/2".

1 Like

Duh, I saw the decimal (0.041631) but forgot to convert it from feet to inches. I am redrawing the plans I purchased from an architect so I just assumed the rounded number (24’) he showed was correct and did not think about the conversion. I should have realized it was likely his math, as he rounded several values, and had errors (as much as 10’) in some of his measurements.

Thanks!

I did some experimenting and found that (at least in SU 2021 on Mac) in Architectural Units, things such as dimensions never show the ~ when feet are present, regardless of whether the inches are imprecise or rounded. With 1/2" precision set, you will get a display of 1’ 1/2" for anything in the range 1’ 1/4" to 1’ 47/64" (1/64" less than 1’ 3/4"). In this screenshot, one edge is exactly 1’ 1/4" and the other is exactly 1’ 47/64". Neither is 1’ 1/2"!

You can form your own opinion whether this is a bug or intentional, but if intentional the training certainly should point it out!

Edit: I didn’t go poking to find out how close to 1/4" would round up to 1/2" or below 3/4" would not round down. It seemed the point was made.

Edit 2: Here’s an amended screenshot that shows how absurd drawings can result:

Interesting observation.

It would explain something that puzzled me a couple of days ago. I selected several dimensions in feet, inches and fractions, not showing the ~ for ‘not exact’, but when I used TIG’s Dual Dimension plugin to show corresponding dimensions in mm along with ft-inch-fraction dimensions, those got a tilde.

I didn’t realise the native dimension was not exact.

Mmmmmmmmmm…I’ll stick with mm

2 Likes