3D Warehouse just keeps loading

I have the same problem with my SKP 2021. Tried all the given fixes but nothing worked for me. Is this only a problem for 2021 version?


SketchUp 2021 is supported and was tested.
It’s working for me. I’ll keep an eye out for how this unfolds.

Hi! I may have missed it, but do you have another browser installed? Wondering if it works in Chrome or Safari for you.

mine too! The 3D warehouse window in app just loads the whole time. However, there are no problems in the web :slight_smile: Can someone help me?? I use SketchUp Pro 2021.

i have the same problem, i didn’t understand what’s wrong with it, and btw, i’m using SKP21

I have the same problem too.

delete the webcache folder on your computer
Make sure sketchup isn’t running

C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp 2023

Sketchup folder doesn’t show up.
C:\Users\Default\AppData\Roaming\Microsoft

What I do?

Do you use the account DEFAULT to access windows?

You can also paste

%appdata%\SketchUp\SketchUp 2023

into the address bar of the folder window to take you to your own folder if you don’t know which one you are.

i reinstall sketchup also not working , i have the same problem

I have deleted the Webcache folder but it doesn’t works.

same here

Same here … after clearing cache data wont help
2021pro version

Are you subscription users?

in sketchup for web 3d warehouse works … but in apk not … what can be wrong ?

it is matter ? if I can download anything from sketchup web … load there model then download as a skp file and later on load it ? it does not affect licensing i think or ?

3DW is still down for us 2021 users. Same with others here, deleting web cache and clearing browser cookies did not resolved the issue. Hoping for a fix soon.

For some 2021 users, it works ok for me and some others who have posted here.

I’ve tried every suggestion posted up here, I thought its was a problem with the new update for 3DW, but if it didn’t get fixed by now maybe it’s something else, don’t know, probably just going to a newer version of SU will fix it.

If you behind some strict corporate firewall that could be a reason. Go to home office :wink: , that worked for me…