3D Warehouse bug

The 3D Warehouse doesn’t work on my Macbook Pro with neither SU 2022 nor SU 2023.

When I accessed the 3DWH directly, outside of SU, it worked but now it doesn’t.

When I click to change category, for example from Model to Collection, I see a quick flash of a page then the image get white again.

Hi, @jean_lemire_1 - I have almost the same laptop, except my graphics card is a different AMD model. Do you still have my email from 3D Basecamp? If so, send me a screen recording of what you’re seeing, and if not send me a private msg and I’ll forward it to you.

Do you have your Mac set to NOT switch over to Intel on lower power? I’ll try mine on Intel graphics and see if I can repro this.


1 Like

Hey jean_lemire_1!

This is a scenario that we tested and I just tested SketchUp 2023 with my Macbook Pro M1. Things worked well although, when I selected Catalogs, I saw the skeleton loader cards for longer than expected. Our new servers are still struggling to get the caching back to production levels.

Would you mind going to https://fast.com/ and letting me know what your internet speed is?

I get 100 Mbits/sec.

Ok, that’s plenty fast enough.

A network issue is unlikely, since 3D Warehouse used to work on your computer. I assume it worked recently. BUT for it to NOT work with either of the two latest versions of SketchUp? That sounds suspiciously like a network security or antivirus situation.

This is what I did:

1 - Unchecked the automatic switching of graphic card in System preferences.

2 - Restarted the Mac

Now it seems to work both in SU 2022 and SU 2023.

Very good! Thanks for reporting back, and glad it’s working.

We’ll keep an eye out for any Intel graphics issues (mine is Intel UHD Graphics 630 1536 MB), and we’ll see if we’ve heard anything from SketchUp’s core team on rendering with Intel.