2016 push/pull double-click pulls in opposite direction

When I double click on a face oriented the same way (NOT one front, one back), the second face is pulled in the opposite direction. So far as I can tell, this only happens in 2016, not 2015. I’m on a Mac. It’s making double-click for push/pull pretty useless for me. As others on the Sketchucation forum are having the same issue, I’m wondering if this is a bug. Anybody with an answer?

Please include sample file, screenshot, and, if possible, a video too ( recommend using http://www.techsmith.com/download/jing/).

What is the behavior when you try the same operation in a new SketchUp file?

Thank you, Yogesh, for your reply.

I am linking a file (PushPull Example 1) I made the day of my query, with three scenes which show what was happening. Today I have to say it just gets weirder and weirder. Today, using the same commands, PP or PP+Optn, to pull up three different faces drawn on the same plane, I get reversed faces on the outside of some but not all the pulled faces (videos PP Ex 2 Reversed Faces and PP Ex3 Reversed Faces), and not every time (see video PP Ex 1 All OK). Today I couldn’t get SketchUp to duplicate what happened in PushPull Example 1 at all. In fact, I copied that file and named it PushPull Example 2, and you can see in Scene 1 it pulled up reverse faces but didn’t push in the wrong direction. I left Scenes 2 and 3 as they were in the original file.

I have to say I’d actually prefer to have to deal with PP push/pulling in the wrong direction over push/pulling with faces reversed, as it’s easier to use inferencing to PP than it is to reverse a bunch of faces. In any event I would think it should work consistently. Any idea what gives? Or maybe it’s just that we get wrong direction on Tuesdays and reversed faces on Thursdays :slight_smile:

BTW, both these problems have been happening for a while, but I just never took the time to document them. Also, just so you and all the folks on the SketchUp Team know, I think SketchUp is a fantastic program, and I do appreciate all the incredible work that has been done and continues to be done to make it such a powerful tool.

As an aside, I downloaded Jing as suggested, but I can’t open those files to see the quality of my videos without loading some other viewer software, which I’d just as soon not do, so I hope you can see them. I may change my mind if I need to do this more often.

Thanks for any insights you might have.

PushPull Example1
PP Ex2 Reversed Faces
PP Ex3 Reversed Faces
PP Ex 1 All OK
PushPull Example2

that’s what the plus + is for, because there all on the same plane, SU doesn’t know if you want a solid or a hole…

BTW, uploading skps direct to the forum is best…

john

John, thank you for your explanation on the reversed faces. Your video on it was particularly helpful. And good to know I should upload rather than link the files. Should I edit my previous post to do that?

So now that you’ve helped me with the reversed faces, here’s an example from this afternoon with double-clicking pushing in the wrong direction again. In the skp file attached Scene 1 shows the beginnings of a quickly modeled cabinet (just geometry, no components/groups). Scene 2 shows the left top face pushed in by a specific distance in the measurement field, but the second face “pushed” in the wrong direction using double-click. Scene 3 shows the left face pushed in, again, by a specific distance, then the second face pushed in by inferencing the first, and then double-click did work correctly on the third and fourth faces. Should not double-click have worked in the Scene 2 scenario as well?

I did videos of this as well so you could see my actions, but I can’t upload them directly using the files made from Jing. Should I add links to files in Dropbox? What did you use to create your gif file?

Just to mix this up even more, I’m not even sure you’ll be able to duplicate my issue when you open the skp file, as I went back into it myself and, sure enough, doing exactly the same steps as outlined in Scene 2, the face pushed in correctly, almost as if SketchUp remembered the correct PushPull from the actions I took in Scene 3.

Obviously I can learn to work around this issue, but as PP is such an integral part of Sketchup and used constantly, it would be nice to know either what I’m doing wrong (if you can even figure that out, given my inconsistent results) or that, heaven forbid :-), it’s a bug.

Thanks again for any assistance, input, etc.
PP Wrong Direction.skp (200.2 KB)

it is a known limitation of PP, that sometimes ‘auto repeat’ gets it wrong…

it happens most often on the ground plane when faces touch like in you first example…

it worked fine for me on your cabinet because those faces have a dividing face between them…

also when I did the first push, I copied the depth to the clipboard, out of habit, just incase the next went wrong…

I also tend to use xRay mode for this type of thing as it helps me with inferencing…

and I would more likely preselect the faces and use the move tool…

I use LiceCap for the gifs, I’m a mac, but others also use it on PC’s…

john

1 Like

John is right. SketchUp is software, so it is of necessity doing exactly what it was programmed to do - but the logic it is following in this case has proven inscrutable to us mere users, and sometimes seems random!

1 Like

Obviously lots and lots of others have, so I guess I, too, will learn to live with that known limitation of “auto repeat.” Thanks so much for clarifying, though, that it indeed is a known issue so I don’t continue to think I’m going nuts – or let it drive me up the wall. And I’ll try to ignore its seeming randomness. Again, thanks for replying.

1 Like