Why so laggy adding objects to entities(SKP PRO 2017)

when adding objects by using entities.add_XXX, e.g., entities.add_instance for 400 times. It takes 3 secs.
how to solve this problem?

Can anyone help or has a workaround? It would be very appreciated.

Use Model#start_operation with the disable_ui parameter set to true to prevent SketchUp from redrawing the view for each change to the model.


It’s exactly what I need!
thank you so much :smiley: