Updated to 2024 and it is basically unusable - screen issue?

Updated a few days ago, was super excited but I cannot work in the program. I work on two screens. An old cheapo screen I bought at Good Will (LG awful brightness and small) which is my reference screen typically and my primary screen that is a very nice gaming monitor (Samsung Odyssey G4).

When SketchUp is opened on my primary screen - I cant orbit, I cant edit things without waiting multiple minutes for it to load. Totally unusable.

When SketchUp is opened on my old cheap screen the program runs perfectly.

I’m going crazy here. Any advice is welcome.

See if going back to the “classic graphic engine” makes a difference.

Also, if you have two graphic cards (Ex: A discreet Nvidia GPU and a Motherboard Integrated Intel GPU) Make sure SketchUp '24 is using the discreet card. If still crashing, experiment using the Integrated GPU.

1 Like

But is it set as the Windows “main” display ?

(On Win 10) At the bottom of Start > Settings> System > Display
… beneath the “Multiple Displays” picklist,
is a checkbox labeled “Make this my main display

The main display (regardless of it’s ordinal number) in Windows is the one that hosts the virtual desktop origin at it’s top left corner, regardless of how it is positioned with respect to other monitors.

Going back to classic graphic engine completely fixed it.

You have no idea how thankful I am!!

Glad that worked out for you! :slight_smile: Hopefully the bugs in SU’24 will get ironed out by the next update.