Unhide rest of model

I am trying to figure out the Sketchup Free web program. Where can I disable the “Hide Model” function when I double click into a group to edit? I like to be able to view the group I am editing while still seeing the entire model. Can anyone help?

I can’t find any such setting in SketchUp Free. I doubt it exists.

Hmmm… I’m not seeing other components disappearing when editing.

The second was drawn entirely in SketchUp Free. I was curious if there’s a difference in where the model was created. There must be a setting some place.

I can’t fin it either but if a model drawn in desktop SketchUp is opened in Free the style will be kept.

Yes. The style will be kept. But the style shouldn’t have any impact on whether or not other stuff gets hidden when a group or component is opened for editing. As I wrote, the second model was done entirely in SU Free and nothing gets hidden when I open a component for editing.

It makes me wonder if this could be a graphics card thing on tdstaub’s computer. Is it possible that a graphics setting fades the other components/groups so much that they aren’t visible on screen?

Hide rest of model is a style property. It doesn’t appear it can be controlled from within SU Free directly but perhaps changing the style would do.

It’s interesting that on the desktop version, it isn’t set under the Style properties in the edit tab and turning on Hide Rest of Model in Model Info>Components doesn’t cause the circular arrows to show indicating that the style has been modified. And when Hide Rest of Model is enabled, it is automatically applied to all styles.

Wait, I think I remembered it wrong :open_mouth: . It’s not a style property but it is saved to scenes as a “Fog and Style” setting. It’s easy to mix up all these concepts!

You could say that again.

1 Like

How about someone saves two model, one with hide others , one with no hide, uploads and sees what happens in Free. I would but can’t on a phone.

Yes. Hide Rest of Model will come over with a model if the setting was made in the desktop version.

What we failed to ask @tdstaub is where the model came from. Was it created in sketchUp Free in the first place or created in a desktop version of SketchUp. It would appear that the problem could be rectified by opening the file in the desktop version and changing the setting before saving it back for use in SketchUp Free.



I made this discussion a separate thread as it is discussing as specific SketchUp Free feature, not (the look and feel of) its interface.

Thank you eneroth3, DaveR and others. Brilliant! The base file I was using was created in the desktop version by someone else that must prefer to edit groups without seeing the entire model. So I opened it up on the desktop version, changed the setting to NOT hide the model, then saved and opened in the browser and it is fixed!
Thanks again! I was about to throw my computer off a cliff.

Also, do you guys know if the web version is the only free version of the Sketchup program now? When I downloaded Sketchup Make to my desktop computer it tells me that I have 27 left on my license…

In the desktop version I constantly toggle hide rest of model when drawing. I even have a shortcut for it because of how practical it is to use. I often toggle in the middle of a drawing operation because I need inference with the rest iof the model to pick one point and need to clearly see the component I’m in to pick another point.

I hope this will soon be added to Free as well.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.