Unable to sign in to SketchUp Viewer on iPhone

I am satisfactorily running SketchUp Viewer on my 2021 11" iPad Pro and needed to also have it on my iPhone 13. I downloaded the app and after clicking on the sign-in button I am presented with a screen that has the Trimble logo, but no fields to enter the login details. If I press “Done”, I get a screen that says “signing in”, “loading”, a Retry button and a cancel (x) button. The cancel button does nothing and the Retry button takes me back to the blank login screen. The only way out is to force quit the app. I am running was running iOS 15.3 and have just updated to 15.4. The issue persists.

Has anyone else experienced this and found a solution, or is it bug.

Since you have not got any answers in 19 days, I want to echo your question. I have the same problem.

You can try to deauthorizing the mobile devices.
In the browser (probably Safari) go to myaccount.trimble.com,
Choose ‘My Products’ then ‘View Included Apps’ and then search for the Mobile Viewer.
Select ‘Manage devices’ and confirm.

If you can’t log in on your mobile device, try to do it on the desktop.
(Note: this will prompt you to sign in on the iPad again as well)

Thank you for trying to help. I have tried your solution but the issue remains. The problem is that there are no login fields showing up on the iPhone app; just a blank page with the Trimble logo and some help/privacy/copyright details at the bottom. The same happens if I access myaccount.trimble.com on the iPhone via Safari, but I can log in via Chrome. However, I still need to sign in via the Viewer app, but that still shows no log in fields.

Do you have any kind of ad blocking in place on your iPhone? I don’t know of such things, but on desktop that has led to the same issue.

The iPhone 13 bug still hasn’t been addressed (May 13,22). I’ve written another plea since this one is due to expire in a couple of days.