The line weight in Layout export to PDF or PNG or JPG

I have some problem with lineweight from Layout when I export it to some other files like PDF, JPG or PNG. In layout everything looks great. The cut lines are thick and looks proper. The problems starts when I export the layout page to some other files. All the lineweights are the same. I used to export it in 300 pixels quality, but even higher doesn’t make any difference. Do you have any solution to this issue?

Can you share a LayOut file that shows this problem? That would make it much easier to give you a solution.

I can do that, but the file is pretty big. I don’t know if the service allow me to send such big file.

Use Drop Box and share the link.

The file is there. It’s quite big around 60 MB. I did change to Hybrid mode to see if it helps. The previous version was Raster.

That would certainly help to improve the output.

That would certainly help to improve the output.

I did change the output settings in the Document Setup in the Raster mode, but it didn’t have any better results.`

The render style of the viewports need to be set to vector or hybrid.
The viewports of the first two pages are still set to ‘raster’ and will be printed as raster.


There is no ‘Raster mode’ in the output setting, just : ‘Low, Medium and Higher’ .
Better ‘raster’ is still raster…It is a good habit to set the display mode to ‘Low’ and then the Output set to ‘High’ for performance.

Oh boy! I’m not sure where to start. I guess we’ll start in SketchUp.

First, part of your file size issue comes from all the styles you’ve played with. You need to purge the unused styles.

There are also 737 components, 129 materials, and a layer that are unused and can be purged. Not only do those things bloat the size of the SketchgUp file, they also bloat the LayOut file.

In LayOut, all of your viewports show as modified. You’ve done something–moved the SketchUp camera, changed the style, or something else–which resulted in disconnecting the viewport from the scene in SketchUp. This means that any scene-specific changes you make in SketchUp will not be reflected in the viewports in LayOut. Style settings are scene specific so any changes you make to the style aren’t going to be correctly displayed.

Best practice is to avoid doing anything to the viewport that makes it modified so that you maintain the link to the SketchUp scene. Also make sure that when you make changes to the style in SketchUp, that you update the style and the scene(s).

Next, for the plan view of the building (Parter - od rezeki) you have the Profiles set to 2 which will make the profile edges of all the groups and components render thick. You have Section Line Width set to 5 which makes those edges even thicker. Those lines seem excessively thick to me. You could reduce both of those. The in LayOut, for that scene, you have the Line Weight multiplier set to 1.2. That makes the line weights of all edges 1.2X thicker than they are set to be in SketchUp.

Exporting your file as a PDF from LO2018 will give you better results because it will handle Anti-aliasing which LO2017 can’t. (A good reason for updating to SU/LO 2018 Pro.

You can get more options for line weights if separate you section slice group to a different layer and show it in a scene by itself. Edit the style for the plan to reduce the weight of the edges including setting the Section Line Width to 1. Use a different style for the section slice only with a heavier line style.

Then stack the section slice scene/viewport in LO over the plan view. I would put the viewports on different layers to make them easier to access. The export will then look more like this:

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.