Support scaling for UHD monitors... and better display scaling implementation in general

I have a 4k laptop and external monitor. They look blurry when run at resolutions below their native maximum. SketchUp’s system requirements page suggests it supports display scaling up to 150%.

However certain parts of the UI start to have issues at anything above 100%. For example the Measurements box starts to truncate the units displayed at even 125%.

I.e. 100% Scaling
Screenshot 2023-11-27 100

125% Scaling
Screenshot 2023-11-27 125

150% Scaling
Screenshot 2023-11-27 150

  1. Can the measurements box receive some tweaks to provide it more space?
  2. Can full scaling options even beyond 150% be implemented for UHD monitors?


Are you really working in mm to the 6th decimal place?

While you await an update that may or may not fix this issue change your units precision to less decimal places and see if that frees up some space.

I hadn’t previously but was just preached to by DaveR that I should in order to reveal imprecise modelling… in this thread:

I also usually turn off the ‘MM’ to save those two extra spaces but had them on here for illustrative purposes.

In any case if I’m drawing a rectangle 5400.00x10800.00 (which I do often) there is still barely enough space to hold all those digits depending on what scaling I’ve got on.

Appreciate the tip though.

Dave wasn’t preaching, he said…

My preference is to model with the Display Precision set as high as it will go for the units I’m working in. When I later create the dimensioned drawings I set the Display Precision to suit the project and the type of measuring tools that would be used in real life.

I provide models and condocs for small scale domestic developments and I have precision set to 0.5mm and have never had issues.

The precision problem you were having was because you had activated length snapping, working with more decimals won’t increase the precision of your model, you can work with 3 decimals and have a precise model or with 6 decimals and have precision issues, it depends on how you model more than the decimals you’re working with.

Note that if you use metric units with Dynamic components, an old bug makes all DCs revert to inches if the “Display units format” box is NOT checked.

Nothing wrong with preaching and I am gratefully taking his advice, so no need to get sensitive. But to my choice of words:

I posted in the feature requests because there is UI issue which affects users with particular hardware and settings and I would like it to go through to SketchUp/Trimble staff who work on these issues. It can and should be improved.

I didn’t ask for workarounds, justifications or anecdotes about you never having any issues. I’m having holes machined in steel RHS using laser and 3 axis water jet cutters and do need precision to a minimum 0.00mm. At least one more decimal place is necessary just for mid points and identification of errors.

1 Like

Appreciate this. I’ll look out for that on the few dynamic components in my library

I’m not suggesting upping display precision will directly increase model precision. I now know and accept imprecision was introduced by length snapping. It does however assist in analysing a past model for errors, as some have only become apparent at the 4th decimal place.

Besides this, I was directly advised by a Sketchup sage to do all my modelling at maximum decimal places for the units of my model and reduce it later for dimensioning. As per the quote above.

I have parts in my models that are at fabrication precision and these are used inside architectural models which must be in MM for dimensioning but which have survey points which import at like 50,000mm from the origin.

If the dialogue box was bigger or at least scaled properly with display settings, nobody including myself would have any complaints.

It’s fine, there’s no rule that forces you to work with n number of decimals, I’m just saying that working with 6 decimals or with 3 decimals doesn’t affect the precision of the modeling, you can work even without decimals but if you type correctly the dimensions, your model will be precise. Personally I work in meters and use 3 decimals but if I need an specific length with more decimals I just type and sketchup will draw with the exact dimensions I’m asking it to do it, even when the exact dimensions are not shown on the measurements box or the entity info tray.

Yeah that’s fine when you are, for example, extruding a newly created component to a known length, but what about when you are push pulling to intersect with a ‘face outside of component’ at a distance which is not known off the top of your head? Or moving a component from some distance away to a meet the vertex of an existing component where you don’t know the distance but want to make absolutely sure it’s a round number?

I’m sure having length snapping off will greatly improve modelling accuracy for me moving forward but being able to see more in the measurement box with display scaling set to 150 or 200% to suit my monitors seems like a reasonable feature request, no?

Can’t the little divider just be moved a little to the left along the bottom bar? :face_with_raised_eyebrow:

Hopefully it will come in 2024 - SketchUp is still living in 2007 when it comes to screen resolution and scaling support