Smoother curved surfaces?

Hello!

I’ve been trying to work on a lot of organic design lately but I can’t find out the reason why my rendered curved surface is not smooth.

SU seems smooth but the rendered image is not … Is there anything I need to set?

Make the surfaces with more dense geometry

Thank you very much!

What about for my counter at the bottom? I can’t find a way to increase density with irregular shape :frowning:

If you used arcs, then increase the number of segments. If you used splines, also, increases the number of segments.

1 Like

Take a look at the subd-plugin from TomTom - it improve organic modelling with shapeways a lot.

2 Likes

Another possibility, which would use the existing SketchUp model with its somewhat coarse curve geometry, is to see if the rendering package has a way to enable what is called “Phong shading” on the surfaces in question. This is what SketchUp uses to render adjacent faces which have been “smoothed” (in SketchUp terms). Phong shading is an algorithmic technique to simulate the visual effect of continuously smooth angles between adjacent flat faces.

3 Likes

Thank you for your reply, you are really helpful! I’m using subdivide to increase the segment and polygon.

But the results is still the same … Is there any simpler way to fix such issue?

You’ll always have the faces in SketchUp. Increasing the number of them by making them smaller will help make the curved surfaces look smoother but there will always be some faceting. It shouldn’t be very noticeable in your current model, though.

I will try it and let you know the result soon! Are you referring to this ThomThom? https://sketchucation.com/pluginstore?pln=tt_autosmooth

This is deep, do you have a website where I could have a read about it?

I’ve increased the segment/polygon. It looks better now but it took me sometime to add the segments =\

I will try with Thom Thom autosmooth soon to show you all the results!

I mean this plugin here: https://evilsoftwareempire.com/subd

Here a example from my work:
Exhaust pipes
Pipes made with 12 segment circle.


1 iteration of subd applied.

The point is, you can switch on and off subd - means you can work on a modell with less faces - gives you a better performance during the modelling process - and finally you apply subd for rendering.
I.e. my Porsche model has a size of 50MB without subd and increase to over 200MB after subd is applied…

And here a example of renders
Without subd


With 1 iteration subd

4 Likes

For the tengel07 suggested option, to use SUbD, you need to create/transform your model to Quads

1 Like

Guess we need to made a Quadface-Subd-Vertex-Tool Tutorial to bring organic modelling forward with sketchup. :smiley:
I like this extension, very useful when you understand the nature of subdivision.

1 Like

Tried all the method but still giving me a little jagged area on the surface =\

Is your model located far away from Origin (0,0,0)? Or do you have custom material and render settings?

With a model created quickly and default materials and settings for render, those jagged edges should not appear

Thats a good example how subdivision helps to get smooth surfaces with less effort.
basic shape - looks smooth in sketchup - but the render shows the real surface


Same shape - subd 3 iterations added - looks much smoother in render.

And, you can switch on/off subd in sketchup for work with the mesh with lower amount of edges and faces.
Cheers
Torsten (maybe a subd addict)

1 Like

Yes, here is the Wikipedia page on Phong Shading.

1 Like

Thank you everybody especially @mihai.s, with your solution I’m able to fix most of the thing. I’m still practicing to improve!

1 Like