Sketchup Pro 2024 Crashing on first startup every time

Since installing SU Pro 2024 on my Windows 11Pro Machine, it crashes on my first attempt of the day to launch. Second attempt - after a brief wait, launches correctly. I reset to classic graphics engine, restarted and behavior continues. Perhaps related: I normally set up my workspace extended across two monitors. For all previous versions, my workspace always stuck. That is, on every launch of new or existing file, the workspace opened the same way it was last set up). With SU 2024, it opens with the workspace shrunk to my primary monitor only. What’s up SU 2024?? (Windows 11 Pro, Intel i7-13700, 64GB, RTX 3060Ti)

1 Like

Do they have the same resolution?

When you installed SketchUp 2024 did your right click on the installer and choose Run as administrator?

Have you installed the latest drivers for the graphics card?

Please update your forum profile. It says you are using SketchUp Free (web) 2018 so clearly way out of date.

Yikes - I wasn’t paying attention to my profile at all! Thanks. Updated.
So, yes, two monitors, same resolution (3840x2160). All drivers are up to date. I don’t remember installing as administrator - so probably went with defaults. Do you think these are related issues?

Unless you install by right-clicking the installer and choosing “run as administrator “ there are all sorts of things that can go wrong, up to and including outright crashes. You should try running the installer that way again and choosing repair. Let us know if that fixes the crashes.

Btw this way to install is not unique to SketchUp.

1 Like

OK, will do that RN.

Hard to say but if you don’t use Run as administrator when you install it, Windows may not grant SketchUp permission to write needed files. Close SketchUp now, do a cold reboot of the computer, find the installer in your Downloads folder, right click on it and choose Run as administrator. Then when presented with the options, choose Repair. After it completes do another cold reboot of your computer. It may fix the issue. It’s certainly not going to hurt anything.

Unfortunately - that didn’t do the trick. Program failed to launch on first two attempts. It acts like it wants to – I get the initial screen prompting me to select a new file or recent file and regardless of which one I pick, it just closes. It did launched properly on the third attempt - and not in the extended monitor mode i ended the prior session in.

There have been various issues reported with the new graphics engine, particularly if you have more than one monitor connected. If you can get SketchUp running, it would be worth going to the Settings-> Graphics window and switching to the Use classic graphics engine button, then quit and relaunch SketchUp. Let us know if that improves the situation. If the problem goes away, that’s proof that your issue is entangled with the new graphics engine. Reportedly the developers are woking feverishly to fix problems like this with the new graphics.

So, unfortunately, switching to classic graphics engine, rebooting, etc. didn’t do the trick either. Still crashes on first and often second launch attempt. And workspace still defaults to fit single monitor. Also, now having this very funky rendering of dimensions.

I have a semi-resolution and a workaround.
1st – since switching back to classic graphics engine, SU has only crashed on launch every other time or less. That’s a win.
2nd – I maximized my main workspace to a single monitor and popped out all of my trays to a separate monitor – visually and functionally the same layout I used before except the trays were pinned inside main SU view. Make sense? So I shut down, waited a bit, and restarted. It launched in the same workspace arrangement from the prior session. Another win!

1 Like

So you had the main SketchUp window spanning the two displays before?

Yeah, preciously I always had my trays pinned inside the main SU Window and extended across two monitors.

On your system it may have worked in the past being that they were the same size, resolution and scaling.

But on most systems the two displays will differ, notably as to resolution and display scaling. This presents a challenge to the Qt libraries used for the GUI. Even the Windows OS may have issues with this. I myself never have run a single application window across multiple displays.

Even before you undocked your trays, I was going to suggest it. Application child windows can adapt to the other display’s resolution and scaling as they are dragged across the boundary.

Tried this method - didn’t work. It’s getting worse for me. Files are opened only from the third, fifth, and sometimes only from the seventh or eighth attempt.

Hi @JB16, thansk for the post and sorry to hear you are having difficulty with SketchUp. First up, if you are getting a bugsplat, let us know the number associated with it so we can access the crash report on our end and see if we can nail down a clear cause of the crash. Without that, we can only guess as to what the cause might be.

Also, did you try switching to the classic graphics engine as suggested by slbaumgartner a few posts back? Also, are you running more than one monitor?

Maybe someday the installer will just do that automatically, or instructions with the software will say this. As far as I know they do not.

I believe Microsoft deliberately made that impossible so that rogue software can’t gain the equivalent elevated privileges without user action.