Sketchup for web page is not working

Today, when I try to access the scetchup for web website, a 404 page appears: Page not found. Is this a global problem or is it just me having the problem today? Just a few days ago everything was fine… The browser is firefox, the latest version; I deleted cookies and website data but unfortunately it didn’t help…

Work was being done on the site earlier… please try again and refresh the page.

Strange, It looks like they changed the link to the Sketchup for web page… Until now it was this
https://www.sketchup.com/plans-and-pricing/sketchup-free
So far, I had this link bookmarked and it worked without any problems
And this link works:
Download SketchUp | Free Trial of 3D Modeling Software | SketchUp
the Start modeling button takes us to the login page and starts the applications…

well you had the link to the description of free, that would later bring you to the actual page.

here is the link to the actual page
https://app.sketchup.com/app?hl=en

(didn’t change.)

Yes, you’re right. I just bookmarked it one day and it worked so far… :wink: