Sketch up trial not working

After downloading the application there is a window prompt that reads:Launch Browser Again. But nothing happens. Is there another way to open the application?

update the video driver of your intel HD first.

I made the updates and it is still not working. I also had a firefox browser up to see if the browser was the issue. Still not working.

Did you update from the intel site or let windows update for you?
Windows is not oke, make sure you got the real intel-drivers!

restart Windows and install SketchUp again by launching the SU setup routine by “right-click > Run as Admin”.

SketchUp f. Windows is using internally the Chromium browser engine, ensure that a maybe installed Chrome is not blocked and does not block anything (e.g. script blocker plugins etc.).

I have witnessed a case where the browser window had opened while the browser was still concealed somehow. After you see the Launch Browser Again button, try Alt-Tab to cycle through what is open, to see if there is the sign in web page buried in Firefox’s windows and tabs.