Shadows not working in SketchUp viewer for ipad

Hi, I have a sketchup pro license. I have modeled a new house for a client and have opened the file in sketchup viewer to see what the client would see. I exported the model with shadows on but in the viewer the shadows are off leaving model flat and bland.

I have been through all the settings etc, shadows is ticked, so is on but they are not there. What’s going on? Is this an iOS problem?..