Set rendering option "SectionCutDrawEdges" to false

Hi, setting SectionCutDrawEdges to false does not works fine.

Sketchup.active_model.rendering_options[“SectionCutDrawEdges”] = false

After setting:
1 - the standard Styles panel works bad.
2 - after restarting Sketchup and reopen, I loose the option SectionCutDrawEdges=false
3 - if I open the model in Layout I cant see the result of SectionCutDrawEdges=false.

What I’m doing wrong?

I don’t think this setting is exposed in Styles.

I don’t think too, but what is the meaning of this setting if is not possible to use it in the styling of the scenes? I’m working on solid section generation and it should be very useful to hide section lines and only see the lines of the faces that I’m drawing. Is there a different way to obtain the same result?


This setting seems to be saved directly to the scene, not to the style. The same is the case for Fog which in the UI is exposed separately from Styles, but under the hood they are both RenderingOptions.

Yes it seems but is not persistent over different sessions of Sketchup and, anyway, setting it to false causes mistakes on Sketchup’s standard solid fill feature. Solid fill image stops working properly.

You may also need to …

scene_page = Sketchup.active_model.selected_page
scene_page.use_rendering_options= true
scene_page.use_section_planes= true
scene_page.use_style= true

Be aware that if you wish different scenes to have different styles, then the scene will need their own style. (It makes makes it easier if the scene page name and their style name is the same.)


Maybe I do something wrong:
this is my test model:

A simple model with a sectionPlane Active and some standard setting in the only one current style.

Then I run this code:

scene_page = Sketchup.active_model.pages.selected_page
scene_page.use_rendering_options= true
scene_page.use_section_planes= true
scene_page.use_style= true
Sketchup.active_model.rendering_options['DisplaySectionCuts'] = true
Sketchup.active_model.rendering_options['SectionCutFilled'] = true
Sketchup.active_model.rendering_options["SectionCutDrawEdges"] = false

And this is the result:

Now I manually save the current style setting with all options checked

I update the scene settings and I save the model.

At the end I close my model but, when I re-open it, I find that the ‘Sketchup.active_model.rendering_options[“SectionCutDrawEdges”]’ is ‘true’ again and this is the situation:

Mybe the Sketchup.active_model.rendering_options[“SectionCutDrawEdges”] is not persistent?


Your forum profile does not give your SketchUp version. Please update this.

Please post code not images of code

Why wrap this up in and if true block ? (It serves no purpose, and is not indented BTW.)

Could be a bug. Have you checked the official API issue tracker for an open issue ?
If there is not one, please log an issue, with sample code and model file.

Yes I think I remember this coming up in recent forum discussion.

We can only set the width of section cut edges between 1…20 manually in the style “Modeling” settings.

We should be able to set width to 0 for off (ie, “SectionCutDrawEdges” as false.)