Replacing new objects in model

How do you replace objects (trees) in a landscape of Sketchup to take take the exact same place of the old trees. The new trees have more variety unlike the trees in the model being replaced which are identical and less realistic. The new trees will need to be in the same exact place as the orignally planted ones. There are numerous trees, is there a tool / extension that increases the process instead of replacing each of them at a time? two examples attached. Thanks

If they are components, select the ones you want to replace in the model and then, in the Components panel, right click on the thumbnail of the one you want to replace them with and choose Replace Selected. If you want to replace all of one components with another, right click on the thumbnail of the first in the Components panel and choose Select Instances. Then right click on the thumbnail for the second and choose Replace Selected.

Note that the component origins are the insertion points so the replacement will go in with its origin in the same location as the origin of the one getting replaced.


Thanks, thats perfect. It will save me a lot of time. There’s an extension called “copy along path” but I don’t think it work as good.

That is for something different.


Make sure the components you are replacing as well as the ones you are replacing them with have the correct scale before you start. If you scale components without opening them for editng you have to remember to scale the definition, too. Right click on the component in the model space and choose Scale Definition.

In advanced attributes tab, “Size ‘enter definition size’” in the edit box, is this where to set the size ? I uploaded another screen sample of the components box where the advance attributes, Is the scale set by inches or feet? I scaled them from the start. They have to be scaled within the editing box after right clicking create component?

No! Do what I wrote.

I found it, sorry I wasn’t checking thoroghly enough ! Thanks, the only problem left is I found that the “Scale Definitions” line item which is about halfway down the draw down menu after right cliking on the tree object, the “Scale Definitions” is Greyed-Out, and unable to activate.

Did you check both components? If both are currently scaled correctly, you’ll have to resize the one that’s too large and correct its definition so it matches the other one for size…

I clicked on “Scale Definitions” which was not greyed out, which is normal. But there was nothing that followed, no dialogue box. Then I did the replacement of components from the display trey, and continues to give a disproportionatly large tree. The size of the original component is 75’ and transfers to 150’ . I resize both components to the same size of scale, including the one that is disproportionately large.

There won’t be an dialog box or anything. The component’s scale definition just gets update to match the current scale of the object.

At least one if not both need to have their scale corrected to match the other one. If you open the component for editing and scale the geometery inside, that will scale the definition. Try that.


Hello again,
The objects are still not matching. Is reset scale or definition scale used? I tried both. There is also the component attributes and component options under dynamic components in the drop menu, and set the preferred measurements for Length X and Length Z and resulted with disproportionate scale when using “replacement selected” in the default trey