Reduce Model Size for 3D Printing


#1

Hi everyone,

I’m trying to modify a model based on a part of my home town (Montreal) for a 3D printing project but I’m having a hard time doing that because the file is big (145Mb) even if I reduced the whole model size from 64km2 to only 6cm x 6cm. I tried cleaning-up and fixing without any notable file size reduction. The model was generated using https://cadmapper.com/ and saved in .skp

With that file size it’s almost impossible to do anything without Sketchup freezing all the time and for very long.

Is there a quick fix to this issue?

Thanks!


Reduce a file in size
#2

I’m currently studying architecture,and the best way to go with these huge models,it’s to use as less geometry,as possible.If you are going to print it on 6cm by 6cm(for example) all at once,your printer it’s not gona get any detail,it will just be a piece of flat clay.I suggest two options:
1.Simplify your model by using as less geometry possible.
or
2.Try printing on a bigger scale,and seperate the model into blocks,if thats possible for you.Than put the printed blocks together.


#3

@manuel.desrochers: This doesn’t answer your question but I did want to clarify.

It is not the size or scale of the geometry in the model that makes the file size large. It is the amount of geometry. The number of edges and faces in the model is directly related to the size of the .skp on disc and in memory.

So as @RedonMiha says, you could divide the model into 4 or 9 or 16 squares, save each square to its own model file, and try printing each separately.

Also, you might be able to help the “flatness” by scaling the model in the Z axis.


#4

To those who answered. Is too much geometry a problem that can be solved with better hardware or is it inherent in the software? I assume the former but you never know…


#5

Have you tried purging the file?