Problems Login: stuck in the loop with the "Are you in the right place"


We are from Colégio do Sagrado Coração de Maria, in Lisboa, and we are encountering lots of difficulties at our school with accessing SketchUp, for our students and for our teachers. When they try to start SketchUp for Schools through Google, they remain stuck in the loop with the “Are you in the right place” error and the login attempt. A very few users are capable of using SketchUp for Schools without being stuck on that loop, all with admin privileges in Google.

We have been using SketchUp for School for several years and the problem started recently. We have followed every single step suggested in this forum.

We have verified popups settings and they are ok. We cleared browser’s cache, cookies, and history, … We have the app enabled. SketchUp for Schools is active for everyone, with permissions for everyone. We have uninstalled and reinstalled the app in Google Admin Console several times. We have tried all of the suggestions.

Our domain is |

I hope that you can help.

Hi @jose.rebelo, thanks for the email and sorry to hear that you are running into issues with the app. It is possible that the firewall is keeping students out although the symptoms you are describing are more in line with something on your end getting fouled up in your settings. The fact that you have tried all the usual steps is a bit odd though as that usually fixes this sort of thing.

I’ll go ahead and get you added to the database once I verify a few things on our end and ping @Tori_SU too so she will be aware of this thread.

Edit 1: Just finished verifying that the app is running as intended. I also have finished adding you to the database so that will rule out any issues on our end. I also recalled a past case that I asked Tori about once and although it was a number of months ago and things may have changed since then, it is worth trying anyway.

That past case required a redeployment of the app after I had done the database editing on our end and required permissions to be re-enabled. Go ahead and give that a try and let me know if it does anything. If we are lucky that will be all we need to do, but if it requires more troubleshooting I’ll await your reply so we can get this worked out.

Also, in case people with a similar issue find this thread in the future, I am linking a video on app deployment so they can make sure they are not missing any steps as they deploy the app.

Thank you for your help, @CaseyG

Now, we have our problem solved and all users can use SketchUp for Schools.

We also verified that Google Classroom authorizations were not properly assigned and we gave permission to all users.

After all of this, now students and teachers are able to use SketchUp for Schools.