Not able to setup VS Code for SketchUp Extension development

Hi Team,
I am not able to configure Visual Studio code with SketchUp. I have set tasks.json and launch.json according to the documentation, even I set “C:\Program Files\SketchUp\SketchUp 2017\SketchUp.exe” -rdebug “ide port=7000” for SketchUp shortcut and still I am not able to open SketchUp through CMD. It always gives SketchUp.exe is not recognized. I have pasted SuRubyDebugger.dll in the installed directory as well. Could anyone please suggest what I am doing wrong or any other steps/documents to follow?
I saw that some issue is also open similar to my issue: https://github.com/SketchUp/sketchup-ruby-debugger/issues/18
Is the VS code is not compatible with SketchUp development?


Error while running task:

1 Like

Have you looked at our VSCode Ruby Extension Project example?

Hi tt_su,

Thank you for replying. Yes, I followed the steps mentioned in this project and while Running tasks SketchUp application is getting launched but debugging is not happening. It is not able to take breakpoints and nothing is happening in SketchUp application.

Hi tt_su,

You can find the sample video recorded. I am new to Ruby and SketchUp so if you can provide me some inputs on how to run the Ruby scripts in VS code/project for SketchUp, that will be very helpful

hm… it looks like things are setup correctly. Unless the DLL is somehow not in the correct place…

What is the output of skippy sketchup:list?


Btw (sidenote), I find that I have to launch and relaunch SU a lot during extension development. The Welcome Dialog can be turned off.
image

Oh, by the way - have you set up SketchUp to load the source files from the repository?

Yes, I believe the DLL path is correct. Please find the screenshot for skippy:sketchup list as well.


Hi tt_su,

I followed Development Setup · SketchUp/sketchup-ruby-api-tutorials Wiki · GitHub
article and created a !external.rb file in Plugins folder. However, I feel that I could’ve missed some steps loading extension. Could you please provide some more inputs on this, how to load the extension? Let me know if we can have a meeting so that we can fix it faster.

That looks correct.

I’m swamped until wednesday. Maybe Thursday? What’s your timezone?

Yeah, Thursday also works fine. My time zone is CEST.

Perfect! I’m the same. Lets sync up then.