New Pc, same old blue circle of hell!

Hi all, Ive recently bought a new pc to speed up my models. The trouble is though, after spending nearly £1000 I still have the blue circle of hell!!! My new processor is an intel core i5-9400 cpu, gtaphics card is an intel UHD graphics 630, operating on windows 10. Have i bought the wrong pc??

Integrated graphics cards have never been recommended for SketchUp and the Intel graphics drivers that Windows supplies generally have provided very poor support for OpenGL which is a required thing for SketchUp.

You also need to ensure that SketchUp is installed correctly on Windows machines. That requires that you right click on the downloaded installer and choose Run as administrator from the Context menu. Did you do that?

Hi DaveR, thanks mate. I really have no idea about this sort of stuff, I can draw nice kitchens on SU but when it comes to the tech bit im a bit stuck! Do you think I can add a different graphics card, if so could you recomend anything? I dont think I installed SketchUp correctly from what you’ve described. Is this something I can go back and re do?

If it’s a laptop, it’s not likely that it was built to have a discreet graphics card installed. I would go back to the people you bought it from to see or to see about replacing it before you get in too much deeper.

As for recommendations, Nvidia graphics card have historically provided the best OpenGL performance. Their current GTX 10xx and 20xx series cards are what you will likely find and any of them will do better than the integrated Intel GPU that you have.

All that said, some people manage to get by with the integrated GPUs but there are loads of reports of problems.

As for the installation of SketchUp, you can correct it. Make sure SketchUp and LayOut are both closed, first. Find the downloaded installer, right click on it and choose Run as administrator. Then, when presented the options, choose Repair.

1 Like

Thanks DaveR, I found the solution!! I had put the hdmi cable into the wrong port on my pc. Turns out I have Nvidia GeForce GTX 1050 Ti all along. What a donut!!
I bought the new pc due to my old laptop being slow. I had a blue circle appearing on most actions and so invested in something more powerful. I’m still getting the blue circle, not as much as before but I thought it may go altogether. Do you have any idea on how to speed up my new pc or should I really have bought something more powerful??

2 Likes

how large are your files in general?
Note: It is not just the size in MB, but the number of polygons or edges that have more impact on performance.

1 Like

Did you setup sketchup to run with the right graphic card?
Nvidia control panel is a helpful place to setup the right config for sketchup.
On my laptop i have a intel hd and a nvida graphic card and i had to adjust via nvidia control panel to run sketchup with the nvidia card.

1 Like

The current model is 240,924 KB. How would I find or reduce the number of polygons or edges? I’m currently modelling with default ‘shaded’ style to help speed things up. I have also purged any unused data from the model, halving its size…

I think so, although it wasn’t as obvious whether I got that part right or not.

Desktop
Right click
Nvidia control panel
Manage 3D settings
Program settings
1.Select a programme to customize:
Trimble SketchUp
Add

Is this the right process??

Perfect.
Other way:
Right click on icon and select the right graphics processor:

1 Like

On Laptops, this certainly is. Otherwise, battery management of the machine will set it to use the internal graphics, only.(To get the promised 9-hour youtubing) Don’t forget to hit ‘Apply’

1 Like

This is the spec of my new pc -

9th Gen Intel® Core™ i5 9400 (6-Core, 9MB Cache, up to 4.1GHz with Intel® Turbo Boost Technology)
Windows 10 Home (64Bit)
NVIDIA® GeForce® GTX 1050 Ti 4GB GDDR5
8GB 1x8GB DDR4 2666MHz Memory
256GB M.2 PCIe NVMe SSD (Boot) + 1TB 7200RPM 3.5" SATA HDD (Storage)

Still getting the blue circle though… a lot!
Any ideas??

More memory you need young padawan - 16gb makes your day.

1 Like

Ok, so processor is good, operating system good, graphics card good, just need to upgrade my RAM?
New this wasn’t going to be easy!! :rofl::rofl:

my models usually do not make it to 25-50MB, or an edge count that surpasses 2 million edges.

I do get a lot of files to check (350MB~2.7 GB)
Usual suspects:

Materials - I use Material resizer from the extension Warehouse to reduce
Edges etc. (Clean Up 3 from Thom Thom)
Proper use of components ie. replacing identical groups by components (Select toys from Thomthom)
Hierarchy - (nesting to deep also is troubling)
Get rid of imported dwg’s
Common sense

Haha, common sense, I could do with some of that!! :rofl:
Ok, thanks I’ll try the material resizer. I always use components so I don’t think its groups that’s slowing the model…

Hahaha 2.7Gb models… wow that beats anything I have ever seen… was it a REVIT import?

PS I freak out if my models approach 100Mb… preferably sub 50Mb.

Typically large urban areas, highrise towers etc