Need some help cutting stairs through the roof!

Hey guys!

Basically i downloaded the GKWare curved stair plugin and i created the stairs i needed but now i am struggling with cutting them through the ceiling/bottom of the first floor. As you can see in the first two gyazo links i attempted to make vertical lines on the edges of the stairs to create the cutout shape on the first floor so i could remove it. How do i go about cutting this shape out? i would usually pull it upwards and remove the lines but as you can see in the 3rd and 4th links the whole floor gets selected and not just the curved shape :confused: what have i done wrong guys? I have never had to do something like this before, especially with A complicated shape so im really stuck!

TIG’s extrude edges by vector might do the trick for you. You just have to isolate the curve in question.


Whats TIG Mate? it looks like it would do the trick!

Tigs extrude edges by vector


Unfortunately it doesn’t work, the plugin i used to create the stair’s make them a whole entity and that plugin only allows you to extrude a single face :confused: any other ideas?

No doubt the staircase is part of a group, so you need to enter the group for editing, isolate and select the segments of the curve, copy them and paste them outside the group.
Then use Tig’s EEbV on the resultant curve.
Here is a simple version.

Come to think of it, you don’t even need to paste outside the group because it creates a new group.

Oh i see! I have had a go and have managed to pull the two curved upwards but its still allowing me to highlight the whole surface instead of just the intersected one! have i done something wrong?

Please add your images directly to the post using the upload icon, Most people don’t want to click a link to an unknown site.
Adding the skp also makes it easier for us to see what your problem is.

Sorry mate, here are two images of what happening, also what is skp? sorry i am fairly new to sketchup and the terms used!

It’s very hard to tell just from the images. There must be a gap somewhere around the perimeter of the edge.

skp is the model file itself. eg: House.skp
the skp needs to be less than 4mb to upload here.
If your model is too big You can copy and paste relevant sections into a blank model and attach that.

The model is still 19,000mb even after removing the majority of the model and leaving the stairs and roof! how comes its so high?

You need to purge the model.

Go Window/Model info/statistics
Tick the little box that says show nested components, then click the Purge unused button.
If it’s still huge you may have imported large materials and they would need to be purged from the materials dialog.There’s a Little button saying Purge unused there also.

The model is still 1000mb even after removing all materials and using the purge unused :confused: is there no other way to send the file? also i appreciate the help mate.

Are you sure about that, 1000mb is huge. Perhaps you are misreading it and it’s 1000kb.

You would be correct! i misread it indeed mate, heres the file!model11.skp (1.1 MB)

Too late for me to look at it now. I’m in the pub. Hopefully someone can help you sooner than me.

no problem mate, have a good one.

there is a gap between these two colors…
turn off shadows, smooth the faces and it’s easier to find this try of gap…
also reverse the floor face and use ‘Intersect with Model’ on it, fix the gap, close the ends and push/pull to the ceiling below…

After you fix the tiny gap problem - remember that the hole needs to be bigger that the stairs otherwise you’ll get a finger-trap as the handrail crosses the edge of the hole in the floor…
Perhaps use Offset + a few hand-drawn edges to complete a face.
Then you can do a PushPull to make the hole in the floor…

Also note that your floor faces are back to front. You should never see the 'blue' backs of faces Select such faces and use the context-menu to reverse them.

There is a narrow surface where the stringer makes a corner with the original floor. The source of your gap is likely that you missed that little bit while selecting the geometry to extrude by vector.