Light material colours display white with view aligned in parallel projection

This has always been the case ever since I started using Sketchup but I’m just curious as to why this occurs and If there is a work around for it. Colours display fine once the view is rotated to a perspective/oblique angle. I assume it has something to do with how the surface are ‘lit’ by universal lighting with shadows turned off. Colour used is 0090_LightCyan.

Thanks for your help

SketchUp changes shades of surfaces to give the appearance of three dimensions, as the camera moves the surfaces are shaded differently. It is an intended part of the rendering.

Open the Shadows Settings pallet, check use sun for shading, and set the dark slider to 100. This will give all surfaces the same color regardless of angle.

I think that is pretty much it - if you want flat/colouer tick the “use sun for shading” box , set light shadow to 0 and dark to 80.
Anything directly facing the sun should be the correct colour.

I think there is an extension that does this in one click, but I can’t for the life for me think of the name

Thanks Adam.

This works to bring the ‘LightCyan’ coloured components up to a more ‘normal’ representation but it also darkens the colour of the other Green and Dark Khaki components in the view. This makes it challenging if I am using a colour coded key in my Layout doc to identify the elements, the colours will look a bit off. Not the end of the earth but just inconsistent. I had thought about doing ‘colour by tag’ as the style but this doesn’t really work with my tagging structure as it stands currently.

My usual method is to avoid colours light enough to cause this problem.

At 100 for the dark slider nothing changes. It has to be at about 80 to bring up the LightCyan from white as @Elmtec-Adam suggested. Appreciate your input though.

If I have shadows off, Use Sun for Shading selected, dark set to 100 and light set to 0 then I get no shading, the color of every surface is the same regardless of viewing angle. I suppose the lighter colors might need only 80? I have not done a color check agains the true color for this.

Try setting to parallel projection and plan view…

Huh, I don’t see a color change in PP or any view, still the same color. Are you seeing a change when you go to PP? Do you have the light slider set to 0?

yes. If I’m in plan and do the settings you suggested the light cyan members remain white. I don’t know how to do video screen recording or I would show you

I trust you :grinning: just genuinely trying to get to the bottom of your request. Can you post the File? or just that one piece that behaves this way?

Also are you using the exact same “named colour” 009LightCyan? yours looks darker to me me…

Can’t post the file as it’s all proprietary/ patent pending stuff.

No I was using a random color. I’ll get the hex code and try with your color… I’m sure you are not crazy, just curious…

Yup totally disappears, looks like a limitation of OpenGL? Problem is as you said setting the dark slider to around 80 is a guess. Hmmm I’ll have to ponder this one.

Solution for me at present then remains(as I have usually done) - don’t use colours lighter than a certain threshold if producing 2D views and diagrams.

Looks like the threshold is around 210 for the red on the RGB sliders, @ 200 I get a light blue that shows.
I don’t see a change in perspective or PP with that color. Good Luck.

Legend. Cheers.

You’ve also led me to update Snipping Tool in windows which now supports video screen capture. :call_me_hand:


Parallel projection and Plan view :

The chosen colours in the material panel will be the EXACT same color as the objects in the viewport.

light 0
Dark 80
Use Sun as Shading on

This works for all colours and textures:
I have a light grey 229, 229, 225
Check the surface of the cube vs what is in the colour picker and you’ll see it matches (within some rounding errors)

going above 80 will produce incorrect results